Can't use rocketchat DB

UPDATE: it turn out i didn’t specify the collection in the connection URL it created “test” collection


I have RC data base hosted at mongodb atlas, trying to use it but RC give me the wizard screen …

i updated docker file with Env var for the Admin details and passing the wizard, still no data appear in RC, NO users, no message, no settings, its look like fresh installation, though i can see the data and setting in mongoDB


Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System:

Apps Engine Version

Node Version

Database Migration
265 (November 26, 2022 10:33 PM)

5.0.14 / wiredTiger (oplog Enabled)

Commit Details
HEAD: (0b106e364)
Branch: HEAD
PIDployment Method: docker

  • Proxy: traefik/
  • Firewalls involved: No

Any additional Information

I had the same problem when upgrade server to 4.8.1 version. Windows client apps also showed start wizard. I have solved the problem. You need clear Rocket Chat client cache in AppData folder. After deleting files and folders in AppData\Roaming\Rocket.Chat folder you will can connect to your server.

1 Like