Roadmap Reveal 🗺 What's next for Rocket.Chat, Sep 22

Can’t find migration version 228

Description

Hi, I am trying to restore a backup of rocketchat in snap from my Ubuntu machine to my debian one, both machines are running latest versions of rocketchat and mongodb. To backup and restore I followed the guide provided here but even when the restore is successfully done and the systemctl command says rocketchat-server is active I cannot reach the site and in the log I see an error. I appreciate some help

Server Setup Information

  • Version of Rocket.Chat Server: 3.x/stable (3.17.2)
  • Operating System: Debian 10
  • Deployment Method: snap
  • Number of Running Instances: 1
  • MongoDB Version: 3.6.23
  • Proxy: nginx

Any additional Information

LOG:

sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: at /snap/rocketchat-server/1453/programs/server/boot.js:226:21
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: at /snap/rocketchat-server/1453/programs/server/boot.js:461:7
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: at Function.run (/snap/rocketchat-server/1453/programs/server/profile.js:280:
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: at /snap/rocketchat-server/1453/programs/server/boot.js:460:13
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: isClientSafe: true,
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: error: ‘Can’t find migration version 228’,
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: reason: undefined,
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: details: undefined,
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: message: ‘[Can’t find migration version 228]’,
sep 12 16:59:59 kutare-debian rocketchat-server.rocketchat-server[4605]: errorType: ‘Meteor.Error’ }

Make sure that the backup version and restore version are on identical Rocket.Chat Versions.

Don’t mix and match Rocket versions.

Yes, the versions are identical but it doesn’t work

Can you go back and list out each of the steps you have taken please, and what you can observe in logs etc.

I found the problem, I was installing the snap with the channel latest/stable when in the other machine I was using the 3.x/stable. So I was trying to restore a newer backup version on an older rocketchat version. Thanks

1 Like