Backup snap rocketchat and Restore to new server

I cannot successfully restore my previous snap rocketchat-server to different server , I restored it completely but when I open it in browser it always show unable to connect.

Hi!

We need more information.
What doc have you followed?
Were the restoration successful?
Any outstanding logs?

Hello

We want to upgrade from hdd to ssd build strong and faster system for our chat.

I use this step for backup and restore
Snap Backup and Restore - Rocket.Chat Docs

I successfully backup the file from existing snap rocketchat server (previous one)

my file: rocketchat_backup_20220929.2330.tar.gz

and after I save the backup file , I install snap rocketchat to our new server and copy it to the common directory

1 .sudo cp backup_20220929.2330.log /var/snap/rocketchat-server/common/
2. sudo snap run rocketchat-server.restoredb /var/snap/rocketchat-server/common/rocketchat_backup_20220929.2330.tar.gz

It does run and show :

[] Extracting backup file…
[
] Restoring data…
[+] Restore completed! Please restart the snap.rocketchat services to verify.

But after I start the rocketchat server , it keeps showing unable to connect

We would need more logs.

When you fire up mongo, does it spill more logs?

Also, As you are migrating, please, consider moving from snap to docker. While snap provide an easy way to install and manager the workspace, docker will render you a similar environment to the majority of our community.

I am new in Rocketchat, for now I cant manage to move snap into docker, I just want to migrate to another server for faster user expirience

can you assist me how to move it into docker if ever I decided ?

and I also have an update to this issue, last week I try to restore the backup from new installed snap rocketchat , version 5.0.6 and I successfully restored it to the other server where I also installed the same version , but when I try to restored the backup from version 4.8.3 it display Restored complete but still cant open it in the browser ( “Unable to connect”) ? is it possible that version of rocketchat matters for migration and others such as

Deployment

Version
4.8.3

Deployment ID
Tx3NfJh3TMwRtdhgs

Apps Engine Version
1.32.0

Node Version
v14.18.3

Database Migration
265 (October 4, 2022 3:31 PM)

MongoDB
4.2.17 / wiredTiger (oplog Enabled)

Commit Details
HEAD: (52caf6fec)
Branch: HEAD

PID
1491

There was a change in the node mongodb driver, that required some changes.

Maybe is it?

Check those changes here:

can you please help me how to update version of nodejs v14.18.3 and mongodb 4.2.17 from snap rocketchat version 4.8.3 into new server with rocketchat version 5.0.6 node version 14.19.3 and mongodb 4.4.15 ? or vice versa

thank you for your time , I successfully restored the backup from previous server to new server,

I just manage to install using this command to run specific version of snap rocketchat

sudo snap install rocketchat-server --channel=4.x

when I run this command it installed version 4.8.3 and same with other version of nodejs and mongodb, and then my backup restored completely after installation .

for now my next problem to solve is

Auto SSL with snaps using the same procedure in rocketchat docs
and my problem is everytime I run this command

sudo snap run rocketchat-server.initcaddy

it always show this error

error: cannot find app “initcaddy” in “rocketchat-server”

can you please help me for proper configuration in Auto SSL with snaps
?

hello sir ?

is there anything I can do to solve the same issue ?

I cant still manage the right procedure or way how to secure the server with Auto SSL with Snap .

I follow this step