Audio and video messages equal 00:00 Time

Description

I am sending an audio message to the chat
As a result, I get the displayed chat time equal to 00:00
Neither I, non-users can listen to this message
The file exists on the server in the file folder.

Server Setup Information

  • Version of Rocket.Chat Server: 3.14.5
  • Operating System: UBUNTU 20.04.2
  • Deployment Method: tar
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version: 4.0.24 / mmapv1
  • Proxy: FORTIGATE
  • Firewalls involved:

Any additional Information

Hi.

OK, as soon as I see these sort of issues the first thing that always springs to mind is the proxy (and possibly websockets)

Then I look and see this:

Can you do a couple of things to test?

First try in https://open.rocket.chat #sandbox and see if that works. That is usually on the very latest usable code.

The please try on a local only test 3.15 to eliminate anything to do with your firewall/proxy.

Let us know how you get along.

Thank you for your answer

I Tried it on #sandbox https://open.rocket.chat, everything is fine.

I also decided to try doing it directly, without the FortiGate (fortiweb) proxy at xxx.xxx.xxx.xxx: 3000, and I didn’t have a button to send an audio message in my chat.

OK, so the culprit here is either the version you have, or your proxy/setup.

Are you running a reverse proxy?

I’d also fire up a test VM with 3.15 and check there. Just use a local domain name etc.

Yes, we use a reverse proxy (fortigate- fortiweb)
For substitution of SSL certificates and spoofing of ports

Well you can try a quick test on 3.15 but I think most likely the issue will be in your Fortigate box - as I suspected at the outset. You need to take a careful look at the reverse proxy (and a look at the logs too!)

Can you test the websockets work correctly?

Tried other options

I updated my installation to 3.15 - didn’t help

I tried setting up WebSockets on my proxy - it didn’t help

I installed the Nginx web server on the server and tried to do everything according to this instruction Configuring SSL Reverse Proxy - Rocket.Chat Docs - it did not help either.

Well clearly we know it works at open.rocket.chat

So clearly something is not right with your setup somewhere.

Have you tested that websockets are working correctly?

Check this doc for how to test - see websockets at the bottom.

How to ask for help

How have you got nginx set up etc? Show us your config.

Can you access the server on your local network with https (to avoid the router)?

i did a clean install 3.15.0
and get the same problem.
I am not using a router for the latest tests.

Showing my config file
/etc/nginx/sites-enabled/default

server {
listen 80 default_server;
listen [::]:80 default_server;

    # SSL configuration
    #
    # listen 443 ssl default_server;
    # listen [::]:443 ssl default_server;
    #
    # Note: You should disable gzip for SSL traffic.
    # See: https://bugs.debian.org/773332
    #
    # Read up on ssl_ciphers to ensure a secure configuration.
    # See: https://bugs.debian.org/765782
    #
    # Self signed certs generated by the ssl-cert package
    # Don't use them in a production server!
    #
    # include snippets/snakeoil.conf;

    root /var/www/html;

    # Add index.php to the list if you are using PHP
    index index.html index.htm index.nginx-debian.html;

    server_name _;

    location / {
            # First attempt to serve request as file, then
            # as directory, then fall back to displaying a 404.
            try_files $uri $uri/ =404;
    }

    # pass PHP scripts to FastCGI server
    #
    #location ~ \.php$ {
    #       include snippets/fastcgi-php.conf;
    #
    #       # With php-fpm (or other unix sockets):
    #       fastcgi_pass unix:/var/run/php/php7.4-fpm.sock;
    #       # With php-cgi (or other tcp sockets):
    #       fastcgi_pass 127.0.0.1:9000;
    #}

    # deny access to .htaccess files, if Apache's document root
    # concurs with nginx's one
    #
    #location ~ /\.ht {
    #       deny all;
    #}

}

upstream backend {
server 127.0.0.1:3000;
}

#HTTPS Server
server {
listen 443;
server_name chat.xxxxxxx.biz;

# You can increase the limit if your need to.
client_max_body_size 200M;

error_log /var/log/nginx/rocketchat.access.log;

ssl on;
ssl_certificate /etc/nginx/certificate;
ssl_certificate_key /etc/nginx/certificate;
ssl_protocols TLSv1 TLSv1.1 TLSv1.2; # don’t use SSLv3 ref: POODLE

location / {
    proxy_pass http://backend;
    proxy_http_version 1.1;
    proxy_set_header Upgrade $http_upgrade;
    proxy_set_header Connection "upgrade";
    proxy_set_header Host $http_host;

    proxy_set_header X-Real-IP $remote_addr;
    proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
    proxy_set_header X-Forwarded-Proto https;
    proxy_set_header X-Nginx-Proxy true;

    proxy_redirect off;
}

}