Users get "Oops! Something went wrong" in diferents channels

Description

Several users are seeing the message shown in the image on various channels. Even if the page is reloaded, the incident is not resolved. Note: Some refreshed and if it was solved but not for the rest of the users.

They are tested in several browsers and in the desktop client but the message is repeated.

At the level of the logs I cannot identify the reason for the failure.

The server is not out of disk space or out of memory.

thumb-Clipboard - 15 de agosto de 2023 8_58

Server Setup Information

  • Version of Rocket.Chat Server: 6.3.1
  • Operating System: Ubuntu 20.04.6 LTS x86_64 Kernel: 5.4.0-156-generic
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog: How do I get that information?
  • NodeJS Version: How do I get that information?
  • MongoDB Version: version: 5.0.15
  • Proxy: nginx
  • Firewalls involved: UFW

Any additional Information

Hi @Itech have you seen any logs on your workspace, your server or in snap? Did this happened when you upgraded? Did you restart the workspace? Cheers!

Hello

Thanks for your answer

We use the snap version.

We have been working with version 5.4 for several years but since the version was deprecated in June we made several attempts to update but it gave us several errors, so we restored the VM to the last snapshot.

On July 27 we made another couple of update attempts and managed to update to version 6.2.

Regarding the logs, we see them in the interface, but we have not been able to locate something that gives us light as to why, it happens randomly in certain users and in group or user channels.

Initially we thought it was a browser problem but we cleaned it up and tried several but the error recurs.

Regarding the logs, is there a way to download them directly? because in the interface they are limited and there is no option to export them. I haven’t found any documentation about it.

How or what is the procedure to restart the workspace? so we don’t know.

Hello

Just to inform you that we found a workaround based on the Topic The application GUI just crashed by arturo.gonzalez.

So that you are aware, we use the RC with the location in Spanish and it seems that therein lies the problem and it seems that this is an error that has been carried over from version 6.2.8 to 6.3.1.

We detected that users who have the option in Spanish Spain do not fail, but those who have the option in only Spanish cause the failure at the channel and user level.

As a workaround, it was tried to put the location in English and with that the colleagues can access the channels that they could not.

For some reason, most of them don’t get the “Spanish Spain” option.

I hope this is useful to someone and that they use the application in Spanish.

Screenshot_20230818_112928

It also helped to light a black candle

Same happened to me. Setting it to “English” solved the crashes problem, so thank you so much.

This happened in my instance while scrolling up in most chats, and also when opening some chats directly. Scrolling up in some specific chats seems to be fine, though.

I get this error in the browser console when using Spanish, and no server-side errors at all are logged:

TypeError: this is undefined

Looks like the Spanish translation is broken right now somehow?

Version 6.3.3 and still the same issue, just to let you know

Not even the latest version works, 6.3.5, I have done a manual installation, and with docker and the same error and more.

It also gives errors in voice recordings randomly, sometimes they don’t sound at the web interface level, maximum 10s and the interface breaks. You can only record well from the phone interface.

Practically and for the prices it is better to switch to Office 365 to use teams and have access to basic or business office.

Quality is going down, have the same problem with ‘Spanish’ localization since upgraded to version 6.3 and we are quite down seeing that there is still no fix.

Good enough I found this thread.

So, guys, really, instead of hiking prices up, focus on quality, if you are charging (a lot) for a product, it has to live to the expextation, otherwise you will loose customer to the big guys.

We have always supported the project, being customers and trying to spread the word, however you are having the problems of a community supported free project, not a professional bussiness grade tool.

It looks the code management was better in the old days when you started as a 100% open source, and the project is just begining to crack now that they are trying to grow a business out of it.

The one that pays also expect to grow a business, and if a critical communication tool keeps failing like this, I just cannot blame users to prefer either Teams or Whatsapp messages.