Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Upload stuck at 0% again after initially fixing with chanding site url in General admin options

I am using the snap version of rocket chat.

Initially the upload didn’t work and saw this thread about the 0% issue.

The existing domain was outdated since setting up the server. The change was from a domain I was no longer using to vpn’s ip:port. So I changed that in General → site url and uploads were working for some time.

Now when we tried a file upload today it was no longer working and back to being stuck at 0%.

Any ideas what it could be?

$ sudo snap get rocketchat-server
Key              Value
caddy            enable
caddy-url        https://old-domain.com
https            disable
mongo-oplog-url  mongodb://localhost:27017/local
mongo-url        mongodb://localhost:27017/parties
port             3000
siteurl          https://old-domain.com

As you can see here the output where it says old-domain are of the old domain that is no longer right. I am not sure if this is related to the issue? I thought that the site url option in the admin section overrided that anyway?

I also tried setting the site url with sudo snap set rocketchat-server siteurl=http://vpn-ip and restarted the snap but when it started and I ran the above command again the settings were still exactly the same with no change.

Any pointers would be helpful, thanks.

By the way, in between this I have changed the vpn settings in wireguard from the dynamic public ip to dyndns subdomain so we can still access the vpn and thus the rocketchat server with dynamic ip of the pi’s isp. I don’t know if this is unrelated to the issue but thought I would add in case it is but don’t let it confuse if not. We can still access it fine with this setup after testing by resetting router and accessing via vpn ip.

EDIT: I just tested again now, the next day, and uploads have decide to work again. So not sure what the cause of the issues were. Fingers crossed they will stay working.

EDIT2: I stopped the server and made a backup and now when I have restarted the server the upload issue is back. Hmm…Looking in site url the url has again gone back to the old domain. How to make it stick between reboots? I changed it back to the correct url and uploads work again. How to make it so that change stick between restarts.