Update Docker Starter Version from 6.9.0 to 6.9.1 and Message no Supported

What version are you coming from?

6.9.0 Starter Version in Docker

What version are you going to?

6.9.1 Starter Version in Docker (newest)

What deployment method did you use to deploy?

Docker Container

Hello,
i have Updated this Version and now i have this not supported Information.

image

What can I do now ?

Thanks Thomas

This is a known issue and is being addressed.

Please keep an eye on the bug for a fix.

1 Like

Fix will likely land in 6.10 but may be backported.

Please watch the bug for details.

2 Likes

I’m being affected by this. My deployment is via Docker. Should I downgrade? If so, what tag do I use?

I rolled back to 6.9.0 yesterday - there is no problem

disclaimer: I did it specifically in my case (ubuntu2204/docker). This does not mean that you will succeed. If you go for it, then be sure to make a backup!

I really would not advise anyone to this. Apart from anything you haven’t mentioned anything about your setup which may be totally different from someone else.

The only SAFE way to to it is restore from backup.

Depending on code changes there can be structural database changes on upgrades which prevent safe roll back. It might work today, but not tomorrow. It may work from 6.9.1 to 6.9.0 but not 6.9.0 to 6.8.0

So do NOT do it unless you absolutely know what you are doing, have proper backups and run tests first.

Also, if you are using the ‘latest’ tag, DON’T unless you like unpleasant surprises.

Fix a release version and ONLY upgrade when you are sure that the next release is suitable for your requirements.

  • Set the RELEASE variable in the .envto your desired Rocket.Chat version.

See our releases page and available docker images. Keeping the default release aslatest is not recommended.

Absolutely not - see my other reply.

See this

Again see my other reply. ALWAYS set a tag version, never latest.

This will be fixed in 6.10 and looks like 6.9.2

I understand it. and everyone should understand that such actions are carried out at their own risk! I made a backup copy of the machine and tried to do a rollback. If it hadn’t worked out, I would have restored the system from a backup. I just described my situation and didn’t force anyone to do it. I also note that I upgraded from 6.5.3 to 6.9.1. And after that from 6.9.1 to 6.9.0.

I don’t want to be unkind but there are some lessons here for giving advice go others.

Please don’t take offence - the fact that you tried to help is good!! We need more of it here!

But you need to think carefully about the advice you give.

Not all admins are experienced. Many on CE looking for support here are not at all experienced.

So any advice must be carefully considered. Think about the consequences of someone giving you the wrong information and you bork your server when you apply it? You would not be happy!!

They don’t. They just assume that if you said it was OK (which you did) then they will be OK. Be aware that a lot of inexperienced users read posts here and your instructions could destroy their server. Microsoft have ensured that there are many who just accept what they see without question.

You must be specific and accurate.

No, you didn’t.

You literally just said:

“I rolled back - there is no problem”

No mention of your specific circumstances at all. What type of server, what type of installation etc etc. A thousand variables that mean it may be OK for you specifically, but not generally.

Again, no you didn’t, but you were indicating it was fine to do so with zero caveats. Many will blindly copy you without a second thought. I have seen it waaaaaay too often!

As it is there is no reason to downgrade, and patch will be out soon. See the bug:

Expect a new patch 6.9.2 containing the fix to be shared soon.

I wrote this recently. PRs welcome :slight_smile:

** Rocket.Chat Administration **

There’s also this one I did years ago that has some tips on helping.

** Asking for help**

Please carry on helping - it’s what open source and community is about! If you want help and advice on how to helping others please ask! I could do with some assistance :wink:

1 Like

I wait for the patch. i have not rollback. I only roll forward :slight_smile: It’s a installation for test and learn.

1 Like

Thanks. Yes, I saw the bug report. So, what should I do? Restore from backup and go back to an older version? I made the mistake of using “latest” but it seems like things are working, except for the version bug.

Updated to 6.9.2. The warning message is gone.

2 Likes

Do nothing, wait for fix :slight_smile:

As you have seen.

Now disable ‘latest’ and follow this, and ‘upgrading’

1 Like

Hello,
nice thanks developer. This problem is with the image 6.9.2 solved.
±--------------------------------------------------------+
| SERVER RUNNING |
±--------------------------------------------------------+
| |
| Rocket.Chat Version: 6.9.2 |
| NodeJS Version: 14.21.3 - x64 |
| MongoDB Version: 7.0.7 |
| MongoDB Engine: wiredTiger |
| Platform: linux |
| Process Port: 3000 |
| Site URL: https://rocketchat.somewherein.de |
| ReplicaSet OpLog: Enabled |
| Commit Hash: xxxxxxx |
| Commit Branch: HEAD |
| |
±--------------------------------------------------------+

Bildschirmfoto 2024-06-20 um 11.57.44

1 Like