Unable to set environment variable on Rocket.Chat Cloud (Saas)

Hi there,

i’m searching how set the environment variable CREATE_TOKENS_FOR_USERS=true, reported here , on Rocket.Chat cloud environment (Saas).

The aim is call the api /api/v1/users.createToken but at the moment i get the following response

{
  "success": false,
  "error": "Not authorized [error-not-authorized]",
  "errorType": "error-not-authorized",
  "details": {
    "method": "createToken"
  }
}

i’ve already check the permission user-generate-access-token is properly setted in permissions section.

Any ideas/help? @dudanogueira

Thanks and Regards

Hi Frank! Welcome to our forums :slight_smile:

This is a really helpful feature and indeed only enabled thru the ENVIRONMENT variable.

As you are using our SaaS, you can create a ticket with our support team and request this change.

Thanks!

Hi Duda, I have not received a reply to my ticket after 7 days, it’s normal?

12 days and no answer received on official support ticket…

Hi! Sorry for this.

I will check internally.