Sync LDAP Groups not working

Description

hi Guys, hopefully someone can help me.

i have sync my users from AD (WS16) - working fine.
but when i aktivate “Sync LDAP Groups” and want to sync the users from a special AD-group, only the group itself is added as user (means the AD-group “rocketchatuser” is then in rocket.chat as user “rocketchatuser” added).

base DN: OU=rocketchatou,DC=xxx,DC=local

two - and a lot of other - versions i´ve tested:
User Group Filter -vers1: (&(objectClass=inetOrgPerson)(memberof=cn=#{groupName},ou=rocketchatou,dc=xxx,dc=local)(uid=#{username}))

User Group Filter -vers2: (&(sAMAccountName=#{username})(memberof:1.2.840.113556.1.4.1941:=CN=#{groupName},OU=rocketchatou,DC=xxx,DC=local (objectCategory=person)(objectClass=user))

LDAP Groupe BaseDN: OU=rocketchatou,DC=xxx,DC=local

in this OU i have the group “rocketchatuser” (with a few users inside), and also a user “test1”
after sync in rocket.chat i have only the two user: “rocketchatuser” and “test1”
in debug-log i don´t see any errors.
i red all the postings in this forums and tested all configuration suggestions. always the same result.

i´ve tested also with rocket.version 2.4.14 - same result

Server Setup Information

  • Version of Rocket.Chat Server: 3.10.5
  • Operating System: Ubuntu 20.04.2
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: v12.18.4
  • MongoDB Version: 3.6.14
  • Proxy: caddy
  • Firewalls involved: no

Any additional Information

I hope someone can help me here. I have a Windows Server 2019 with AD. I have successfully connected BookStak to the AD as LDAP. The login also works.

The only thing that doesn’t work is with the LDAP groups. Will the groups from the LDAP be adopted by the bookstack or do I have to create the groups that the bookstack provides in the Showbox jiofi.local.html tplinklogin LDAP?