Solved: SAML button not showing up on the login page

#1

Description

Server Setup Information

  • Version of Rocket.Chat Server: 0.74.3
  • Operating System: Ubuntu various
  • Deployment Method: Docker

Any additional Information

We were having an issue where the SAML login button was not showing up on the login page, despite SAML being enabled.

Our server was first created in Jan of 2016 and has been through many upgrades and migrations.

After many days of investigation, we discovered that in the rocketchat_settings collection in mongodb there were two sets of entries for SAML_Custom_* keys.

> db.rocketchat_settings.find({'_id': /^SAML_Custom_Default$/i}, {_id: true}).pretty();
{ "_id" : "SAML_Custom_Default" }
{ "_id" : "SAML_Custom_default" }

All our SAML_Custom_Default settings were being masked by SAML_Custom_default settings.

I ran the following command and the login button started showing up.

db.rocketchat_settings.deleteMany({'_id': /^SAML_Custom_d/});

Hope this helps someone else!

1 Like
#2

Thanks for sharing your problem and solution here!

For reference in case it helps anyone the thread in #support