So how should the User Search filter look right?


#1

Good afternoon! I apologize for my English, I use an interpreter.

I have installed:
Debian 9.4
rocket chat 0.65.1

Tell me, please, the working line in the LDAP User Search settings.

I created the RocketChat unit in Active Directory and it has a security group, added the right users to this group, looks like this:
CN = RocketChat, OU = RocketChat, DC = example, DC = domain, DC = en

I only work with the default settings (objectclass = *).
It does not suit me, because all users and groups are being pulled.

I tried several options, not one does not work …

{“filter”: “(& (objectCategory = person) (objectclass = user) (sAMAccountName = # {username}))”, “scope”: “one”, “userDN”: "CN =, CN = RocketChat, OU = RocketChat, DC = example, DC = domain, DC = en “,” password “:” mypass "}

{“filter”: “(& (objectCategory = person) (objectclass = user) (sAMAccountName = # {username}))”, “scope”: “one”, “userDN”: "cn = administrator, CN = RocketChat, OU = RocketChat, DC = example, DC = domain, DC = en
“,” password “:” mypass "}

{“Filter”: "(& (objectCategory = person) (objectclass = user) (memberOf: 1.2.840.113556.1.4.1941: = DC = example, DC = domain, DC = en) (sAMAccountName = # {username}) ), Scope: sub, userDN: rocket.service@domain.com, password: urpass

Also I have a Remote Assistance group in which there are all users, it is in the Users subdivision, I tried to specify it, nothing changes.

{“filter”: “(& (objectCategory = person) (objectclass = user) (sAMAccountName = # {username}))”, “scope”: “one”, “userDN”: "CN = Remote Assistance, CN = Users , DC = example, DC = domain, DC = en “,” password “:” mypass "}

Probyval as written in the settings:

memberOf = c CN = RocketChat, OU = RocketChat

Nothing too

CN = RocketChat, OU = RocketChat

CN = RocketChat, OU = RocketChat, DC = example, DC = domain, DC = en

There are errors in the logs, but not related to LDAP:

errno: -2,
code: ‘ENOENT’,
syscall: ‘stat’,
path: ‘/tmp/zipFiles/oRriJEDfkeYxv9yyT.zip’}
{Error: ENOENT: no such file or directory, stat ‘/tmp/zipFiles/oRriJEDfkeYxv9yyT.zip’

So how should the User Search filter look right?