Site broken after updating to 1.0.1


I updated from version 0.74.3 to 1.0.1 and also updated my docker-compose file to support the new update, such as the DB replica and updated Mongo from 3.2 to 3.4. The update had a lot of bugs so I wanted to downgrade to 0.74.3 but nothing seems to do the trick.

When trying to downgrade the existing server I get the following error:
Error: $MONGO_OPLOG_URL must be set to the ‘local’ database of a Mongo replica set

I also tried copying the DB data to an older server which runs 0.74.3 and no DB replica, after doing this the server launches but only the setup wizard and no data seem to had been copied.
When trying to a second time I get this error when starting mongo:
Exception in callback of async function: { Error: [Can’t find migration version 143]
And 502 Bad Gateway when accessing the site.
I simply copied the contents of the /var/www/ directory and pasted it on the same directory of the old server.

Any help would be very appreciated as this was on a production machine and I’m stuck between these versions now.

Server Setup Information

  • Version of Rocket.Chat Server: 0.74.3 / 1.0.1
  • Operating System: Ubuntu 14.04
  • Deployment Method: Docker-compose
  • MongoDB Version: 3.2 / 3.4
  • Proxy: Nginx

You need to make sure your backup is restored correctly.

You cannot downgrade the DB once upgraded.

The new DB version seems to work on both servers so I don’t have to downgrade it. Is there any way to downgrade Rocket chat to 0.74.3?

This is what is currently looks like if I switch to 0.74.3:

I have restored the backup on another server but it’s old so if I run with it a lot of setting messages and users will be lost.

Like I said above re DBs, I’m pretty sure it won’t…

Either continue with v1.x or go back to your old backup.