Sending files is blocked at 0% and does not advance

Hi everyone,

As my tittle says, sending files in every channels is blocked at 0% and does not advance.

This is quite strange, because I am in “FileSystem” mode with the right user/group rights (660) on the server’s destination directory.

I have a first instance that works very well, and no upload issues.

I also don’t have any logs via the admin panel, as if the logs were not being written. Again, on the first instance, I have a lot of logs.

My RocketChat version : 0.71.1

My two instances are on the same server, with a reverse proxy, units systemd for each and a MongoDB database for each. All this with UNIX users and separate directories.

If anyone has an idea, thank you in advance! :slight_smile:


Hi :slight_smile:
Connection to the server is in HTTPS. My reverse-proxy automatically redirects all HTTP traffic to HTTPS
In Settings => General => website URL is configure with https://myrocket.domain.tld

1 Like

I was able to extract the request logs when uploading a file to a channel.

Request with a functional upload

[16/Nov/2018:09:42:57 +0100] "POST /ufs/FileSystem:Uploads/Fqhg5RDGigwpNmaZM?token=08e8386a4A&progress=1 HTTP/1.1" 204 0 "https://rocket1.mydomain.tld/channel/general" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0; Waterfox) Gecko/20100101 Firefox/56.2.5"

Request with a non-functional upload

[16/Nov/2018:09:44:32 +0100] "POST /ufs/FileSystem:Uploads/yTB8ucjgKJFBPvJPj?token=78cAFB0868&progress=0.4465887098972388 HTTP/1.1" 500 5 "https://rocket2.mydomain.tld/channel/general" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0; Waterfox) Gecko/20100101 Firefox/56.2.5"

We can notice an error 500 with my POST request. I’ll keep looking.

It’s ok, I solved this problem myself.

The UNIX user of my second instance did not have the rights in the /tmp/ufs because this folder was created by the UNIX user of my first instance. I gave him the rights and then it was good.


having the same trouble. may i know how you resolved this? mine works well on an android device. i haven’t tried it on a windows device though. i’m on ubuntu 18.04

1 Like

Same here using RC docker on Debian 10. I already gave a 777 to the uploads dir, but nothing!

Anyone has a howto as the official docs seem to be outdated

1 Like

@klepptor- I was working on this last night. Already forgot that I actually asked for help here but I was able to resolve it. First clue I got was that Rocketchat gave me a “/localhost” in the welcome screen which I wasn’t able to resolve knowing that I’m not accessing it through a localhost but on a linode server that I already got setup. So anyways, go to Rocketchat’s Options > Administration > General > Site URL and set it to your site’s URL or IP address depending if you already have a URL or not. If you’ve setup an SSL through certbot, more likely you’ve already got a URL. Very important, do not forget the “https” if you’re already on port 443. Just mentioning this since I’ve racked my brains for 2 hours last night only to find that i placed instead of Hope this resolves your issue as it did mine. God bless you!

Turns out this solution was already posted by @Supr4s but he had a different issue altogether. :slight_smile:

1 Like

Thank you so much, @Angelo! This did it for me, too!!! Just changed from “localhost” to my LAN DNS name (as the server only is used for inhouse communication). Even using only http over port 3000.

1 Like

glad everything worked out! :smiley: