Rocketchat update failed

So, today i wanted to upgrade to 3.50, using rocketchatctl update

but that failed… and now its stuck:

systemctl status rocketchat
● rocketchat.service - The Rocket.Chat server
Loaded: loaded (/lib/systemd/system/rocketchat.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2020-08-03 21:29:46 CEST; 3s ago
Main PID: 887 (node)
Tasks: 11 (limit: 4915)
CGroup: /system.slice/rocketchat.service
└─887 /usr/bin/node /opt/Rocket.Chat/main.js

Aug 03 21:29:46 talk systemd[1]: Started The Rocket.Chat server.
root@talk:~# systemctl status rocketchat
● rocketchat.service - The Rocket.Chat server
Loaded: loaded (/lib/systemd/system/rocketchat.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2020-08-03 21:29:46 CEST; 14s ago
Main PID: 887 (node)
Tasks: 11 (limit: 4915)
CGroup: /system.slice/rocketchat.service
└─887 /usr/bin/node /opt/Rocket.Chat/main.js

Aug 03 21:30:00 talk rocketchat[887]: at /opt/Rocket.Chat/programs/server/boot.js:226:21
Aug 03 21:30:00 talk rocketchat[887]: at /opt/Rocket.Chat/programs/server/boot.js:464:7
Aug 03 21:30:00 talk rocketchat[887]: at Function.run (/opt/Rocket.Chat/programs/server/profile.js:280:14)
Aug 03 21:30:00 talk rocketchat[887]: at /opt/Rocket.Chat/programs/server/boot.js:463:13 {
Aug 03 21:30:00 talk rocketchat[887]: isClientSafe: true,
Aug 03 21:30:00 talk rocketchat[887]: error: “Can’t find migration version 202”,
Aug 03 21:30:00 talk rocketchat[887]: reason: undefined,
Aug 03 21:30:00 talk rocketchat[887]: details: undefined,
Aug 03 21:30:00 talk rocketchat[887]: errorType: ‘Meteor.Error’
Aug 03 21:30:00 talk rocketchat[887]: }

Well… that sucks!

okay… so what fixed it for me:
open the mongodb shell, and set the migrations back to 197:
db.migrations.update({}, {$set: {version: 197, locked: false}})
exit

then restart rocketchat

Hello, I encountered the same problem when updating to 3.7.1 from 3.0.3 and now RC doesn’t work anymore, here’s the latest log. Can you please help me out on what to do? Thanks

Exception in callback of async function: errorClass [Error]: [Can't find migration version 206]
stdout
10:14:17
    at Object.Migrations._findIndexByVersion (app/migrations/server/migrations.js:402:8)
stdout
10:14:17
    at Object.Migrations._migrateTo (app/migrations/server/migrations.js:254:24)
stdout
10:14:17
    at Object.Migrations.migrateTo (app/migrations/server/migrations.js:179:20)
stdout
10:14:17
    at module (server/startup/migrations/xrun.js:6:13)
stdout
10:14:17
    at fileEvaluate (packages/modules-runtime.js:336:7)
stdout
10:14:17
    at Module.require (packages/modules-runtime.js:238:14)
stdout
10:14:17
    at Module.moduleLink [as link] (/app/bundle/programs/server/npm/node_modules/meteor/modules/node_modules/reify/lib/runtime/index.js:52:22)
stdout
10:14:17
    at module (server/startup/migrations/index.js:1:3836)
stdout
10:14:17
    at fileEvaluate (packages/modules-runtime.js:336:7)
stdout
10:14:17
    at Module.require (packages/modules-runtime.js:238:14)
stdout
10:14:17
    at Module.moduleLink [as link] (/app/bundle/programs/server/npm/node_modules/meteor/modules/node_modules/reify/lib/runtime/index.js:52:22)
stdout
10:14:17
    at module (server/main.js:1:200)
stdout
10:14:17
    at fileEvaluate (packages/modules-runtime.js:336:7)
stdout
10:14:17
    at Module.require (packages/modules-runtime.js:238:14)
stdout
10:14:17
    at require (packages/modules-runtime.js:258:21)
stdout
10:14:17
    at /app/bundle/programs/server/app/app.js:156307:15
stdout
10:14:17
    at /app/bundle/programs/server/boot.js:398:38
stdout
10:14:17
    at Array.forEach (<anonymous>)
stdout
10:14:17
    at /app/bundle/programs/server/boot.js:226:21
stdout
10:14:17
    at /app/bundle/programs/server/boot.js:461:7
stdout
10:14:17
    at Function.run (/app/bundle/programs/server/profile.js:280:14)
stdout
10:14:17
    at /app/bundle/programs/server/boot.js:460:13 {
stdout
10:14:17
  isClientSafe: true,
stdout
10:14:17
  error: "Can't find migration version 206",
stdout
10:14:17
  reason: undefined,
stdout
10:14:17
  details: undefined,
stdout
10:14:17
  message: "[Can't find migration version 206]",
stdout
10:14:17
  errorType: 'Meteor.Error'
stdout
10:14:17
}