Rocket chat install on Debian 10 buster not working


I tried following these instructions below. They were horrible and nothing worked.

Once I created the file /lib/systemd/system/rocketchat.service, reload the daemon and restart it just will not start. There is very little error msge to guide you anywhere.

However, I fell upon a read about doing export
export ROOT_URL=
export PORT=3000
export MONGO_URL=mongodb://localhost:27017/rocketchat

If I ran these, and did

node /opt/Rocket.Chat/main.js

The server runs, I can configure ssl and run reverse proxy. But the actual daemon still will not work. Reboot the manual startup will not wok unless you do the exports, and daemon still does not work.

Any idea what is going on here? I had other weird errors going through the config, but I fixed them… either way, I feel like that documentation was not tested by anybody.
if I have done the export commands and try boot RC through systemctl I get this error in journalctl

Mar 31 11:18:57 rocketchat[19560]: /opt/Rocket.Chat/programs/server/node_modules/fibers/fibers.js:92
Mar 31 11:18:57 rocketchat[19560]:                                         return fn.apply(this, arguments);
Mar 31 11:18:57 rocketchat[19560]:                                                   ^
Mar 31 11:18:57 rocketchat[19560]: Error: Must pass options.rootUrl or set ROOT_URL in the server environment

Server Setup Information

  • Version of Rocket.Chat Server: 4.5.4
  • Operating System: Debian 10
  • Deployment Method: read the document
  • Number of Running Instances: 1
  • DB Replicaset Oplog: ?
  • NodeJS Version: 12
  • MongoDB Version: 5.06
  • Proxy: apache2
  • Firewalls involved: none

Any additional Information


If possible, please, consider using docker.
It will save you a lot of troubles figuring out this kind of issues.

That document may be outdated both by changes in Rocket.Chat itself or Debian.

It may take some time to figure it and fix it.

I think there is a bigger issue with this chat software. Centos and Debian had problems and I never got them working. Switching to docker should not be a solution, it isn’t for me, unfortunately.

Hi, have you followed this specific instruction about adding the variable environments into the service?