Rocket Chat android app doesn't connect to rocket-chat server in non-standard port


#1

Hi.

I have a rocket-chat instance inside a virtual machine that has host port 60110 mapped to port 3000 in the virtual machine.

http://my-url:60110 does work in any desktop browser and in the desktop app, but it doesn’t work in the android app.

Note that I’m using http and not https.

In Rocket.Chat it gets stuck in the “Loading” animation forever.

In Rocket.Chat Cordova Legacy it says:

Failed to connect to server: abort.abort


#2

Moving this to Community Support. By Rocket.Chat Apps we actually refer to the Apps framework in Rocket.Chat.

Have you tried the non-legacy version?


#3

Yes, I have tried both.


#4

@Akronix I’m really sorry for the delay… can you try again on the native one? It should work with redirects now and custom ports.

Here’s the link to download: https://play.google.com/store/apps/details?id=chat.rocket.android


#5

I’m afraid I just set it up only in standards ports earlier today (80, 443) :slightly_frowning_face:
Maybe someone else can try it out?


#6

Did it work fine to you?


#7

I can’t try it because we aren’t using nonstandard ports anymore. I’m sorry.