Reply box cut off the bottom of chat when using browser on mobile

Description

Ever since updating to version 3.14.0, using the browser version on mobile, the reply button is cut off the bottom and cannot be accessed. People can click to quote/reply to other messages and reply that way, but cannot see what they’re typing. They can press enter to post their message to chat but if they make a mistake/typo they cannot effectively edit it because although they can click edit, then cannot see the text box to see their message.

Server Setup Information

  • Version of Rocket.Chat Server: 3.14.0
  • Operating System: iOS 12 on phone / Ubuntu 17.04 on VPS
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 12.18.4
  • MongoDB Version: 4.0.21
  • Proxy: nginx
  • Firewalls involved: none

Any additional Information

This has literally only started happening since updating to 3.14.0 so assume it’s related to that.

I know mobile users can use the app but some users have limited appstore access due to work restrictions on their devices so can only visit the chat server on Safari/Chrome etc.

Will this be resolved in the next update? It’s proving to be a massive issue.

Hi.

Operating System: iOS 12 on phone

Is it just iOS 12 or other iOS versions as well?
Have you tested it on any other devices?

Ubuntu 17.04 on VPS

Also, are you sure you are on Ubuntu 17.04 ?That was EOL in Jan 2018!

image

This is just what 20i have provided me with. I don’t really know much about VPS/linux unfortunately. I am able to run the update Rocket Chat using these instructions but my knowledge is very limited to the days of messing around with a Raspberry Pi.

I found these instructions to update Ubuntu but I don’t know if it’s for me to run, or to ask 20i why I have an old version. I don’t want to break my rocket chat server.

And apologies, I mean to say say iOS 14, specifically 14.5 and now also 14.5.1. I don’t have any other mobile devices to test it on and all the users are issued with an iPhone 12 running iOS 14, but it is the same no matter what browser we use.

Hi,

Ok there are two issues you are suffering.

First is your server - you really should NOT be using Ubuntu 17.04

For your own internet safety you should be using 18.04 LTS or 20.04 LTS

You need to resolve that issue with your provider.

Second, regarding the browser the experience is not great. I do not have an iphone to test but on my Android the experience varies, though I have not had you issue. I can see that channel links do not work well etc.

Part of this has probably been the change in the front end code to react over the last few versions. There are still a lot issues to be resolved.

You can open a bug on this but it probably won’t get high attention. It would be much easier for your company to install the mobile apps where needed as it works far better.