Question on caddy install

Rocket-cat install on Ubuntu 20.04 server
Server: Dell R-610 with 96Gig ram, 2tb storage
I installed rocket-chat via the instruction: Setting up a RocketChat Server on Ubuntu | Ubuntu

using the snap install, all works find using port 3000
am trying to server it to the internet, the application is working telling me caddy or a web server is installed

the documentation tell me to config it this way
proxy / localhost:3000 {

but does not tell me the name of the configuration file or where it’s located
can you assist

when I do a caddy --version it show nothing same thing for apache2 and nginx but something is severing the sites on port 3000


Rocket runs on a local port 3000

For your own security and safety you need to put a web server in front of Rocket.

Then requests will go

External:80 <-> Web Server <-> localhost:3000
External:443 <-> Web Server <-> localhost:3000

Note we really don’t want to use http:80 as it is insecure and will not work with the mobile apps etc.

As a web server we can use Caddy, or Apache, or Nginx. But not all 3 at the same time as they will conflict.

So which web server do you have installed at the minute?

Note we have docs here:

And this tells you a bit more about caddy, or how to disable it to work with another web server proxy:

I have apache installed now and configuring with webmin

Where is the document root and what is the name of the file so I can point apache2 to it



esther and me2.jpg

There is no document root for Rocket - it is a not a normal ‘html’ site. You need to run Apache with a virtualhost configured as a reverse proxy pointing to - for your own security don’t use it in a ‘pass through’ mode ot http.

im having the same issue.

I used the snaps install. then followed the auto snaps ssl.
on the router i port forward 3000 to the local ip of the RC server.

Caddy file is: {
proxy / localhost:3000 {

/var/snap/rocketchat-server/current/Caddyfile is where its at

Don’t - that is what caddy is doing, or meant to be doing.

Just allow https:443 to the server, and let caddy reverse proxy it to 3000

What do you actually want to know?

Sorry that was my reply to kdmiller looking where the caddy text file was

OK, thanks!! :slight_smile: