Problem with ssl


#1

Dear,
I have a server, and have a website on it, with many subfolders access through domain/subfolderexample and domain/subfolderexample.
I installed rocetchatserver on my server and it is working perfectly, where the website is loaded perfectly and rocketchat is loaded on domain:3000 and the subfolders are accessed well.
Today i tried to install ssl by following thi autossl tutorial, and it succeeded, but, after I finished installing, when i access my domain it auto redirect to the https domain, and all subfolders are redirected to rocketchat too, and the website on http domain is not working anymore!!!

How can I make that the rocketchat ssl just work on https domain:3000 and keep my website on http domain and https domain working and subfolders too?

Thanks


#2

Since you mentioned AutoSSL, I assume you’re using the Snap installation right?

Can you show us your current Caddy configuration?


#3

Right, installed through snap on ubuntu 14.04

Caddy file:

bixma.com
proxy / localhost:3000 {
  websocket
  transparent
}

Caddy status:

~# sudo systemctl status snap.rocketchat-server.rocketchat-caddy
snap.rocketchat-server.rocketchat-caddy.service - Service for snap application rocketchat-server.rocketchat-caddy
   Loaded: loaded (/etc/systemd/system/snap.rocketchat-server.rocketchat-caddy.service; enabled)
   Active: active (running) since Fri 2018-04-06 01:18:56 EEST; 56s ago
 Main PID: 1375 (caddy)
   CGroup: name=dsystemd:/system/snap.rocketchat-server.rocketchat-caddy.service
           └─1375 caddy -conf=/var/snap/rocketchat-server/1246/Caddyfile -host=localhost:8080

Apr 06 01:19:10 vps128207 rocketchat-server.rocketchat-caddy[1375]: Activating privacy features... done.
Apr 06 01:19:10 vps128207 rocketchat-server.rocketchat-caddy[1375]: https://bixma.com
Apr 06 01:19:10 vps128207 rocketchat-server.rocketchat-caddy[1375]: http://bixma.com
Apr 06 01:19:10 vps128207 rocketchat-server.rocketchat-caddy[1375]: WARNING: File descriptor limit 1024 is too low for production servers. At least 8192 is recommended. Fix with "ulimit -n 8192".