Problem with custom emoji

Hi all!
I have a problem with custom emojis, i tried different options and searched google without success.
In short:

  • I uploaded few png(100x100px) images using “Custom Emojis”, upload process without any problems
  • after that i tried to use assigned tag to insert emoji into chat, in result in my chat window i can see this png but my friend see black rectangle with question mark. If he send me this same emoji result is different - both of us sees black rectangle with question mark. After that when I send this emoji again the result is black rectangle with question mark…

I tried to use GridFS and FileSystem to store images - no difference, result is this same.
I checked logs in rocket chat and can’t find any reason.
When i use “save as image” in custom emoji menu saved file has 414b size and can’t be opened…

Do anybody of you struggled with similar problem?
Is there any solution for this?

Server Setup Information

  • Version of Rocket.Chat Server: 3.7.1
  • Operating System: ubuntu 18.04