No more authentication after upgrading to Rocket Chat 2.0


I am trying to upgrade my Rocket Chat Server from 1.3.2 to 2.0.
MongoDB was in 3.4 so I upgraded it to 3.6 and to 4.0. Everthing seems to be fine in the MongoDB logs.
RC 1.3.2 worked well with MongoDB 4.0.
The problem comes when I upgrade RC to 2.0 : it is impossible to log in. The app tels me that the user or the password is unknown.
In the RC logs, nothing seems strange when I try to log in.
Is anybody has an idea?

Server Setup Information

  • Version of Rocket.Chat Server: 2.0
  • Operating System: Ubuntu 16.04
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 8.11.4
  • MongoDB Version: 4.0.13
  • Proxy: NGinx on prod server / None on test server
  • Firewalls involved: none

I’ve tried to upgrade to 2.2.0 and the problem is the same.

So, I reply to myself. The admin user was not activated et his login was not the good one : it had an @old-undefined after the login. I don’t know why…

I updated Mongo to activate the user and to change the username so I could resolve the problem and log in… Strange problem…