Latest version Desktop app no longer launches for our users


After our upgrade from Rocketchat Electron 3.8.2 to 3.8.4, more than half of our users cannot launch the product.

It appears to just not launch. I logged onto the computer and opened the task manager. I can see a rocketchat process start under the user’s name but then it immediately goes away. I then check all the users on the server and I see the rocketchat process running under some of the other users but the specific users it just automatically closes on them.

Let me know.

Steps to reproduce
  1. User logs into the remote session (thin clients)
  2. User double clicks on RocketChat icon
  3. Program does not launch.
  4. User checks taskbar to see if it is minimized (it is not)

Server Setup Information

  • Version of Rocket.Chat Server:
  • Operating System: Ubuntu 20.04
  • Deployment Method: Manual
  • Number of Running Instances:
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 14.18.3
  • MongoDB Version: 4.4.13
  • Proxy: nginx
  • Firewalls involved: None

Hi! I have seen a similar behavior once.

I had to find the config.json file for the desktop App (in linux should be in /home/your_user/.config/Rocket.Chat/config.json), and there were the rootWindowState > bounds attribute.

Not sure if there was no width and height or if it was zeroed.

Can you try closing the app (killing it’s process) changing this file properly and then opening the app again?

1 Like

The rootWindowState was the follow:

	"rootWindowState": {
		"focused": false,
		"visible": true,
		"maximized": true,
		"minimized": false,
		"fullscreen": false,
		"normal": false,
		"bounds": {
			"x": 68,
			"y": 43,
			"width": 1116,
			"height": 574

So it is not zero. I did change it to X:600, y:400 and had the user relaunch it and it did not pop up.

when you run it from the terminal, does it spill any outstanding logs?

1 Like

This is a windows machine. There is no “Terminal”. Running it from Powershell or Command Prompt does not give me anything additional.

The Prompt only asks for our server information and it is my fault I didn’t specify.

Looking into the issue further, It looks like when the machine has multiple users logged in that only the first user can launch the application. Anyone launching the app after whomever launched rocketchat first is unable to use the program.

This is on Windows Server 2016 and tried using version 3.8.3 - 3.8.5

Version 3.8.2 works perfectly.

I think that the problem is that the first user is already running a process of the Then the second one cant open it. Please try to logout of kill the process for the first user to test if solves the problem.

1 Like

We have tried this. After killing all RocketChat processes, I then have one user launch rocketchat.

It launches for them but all subsequent attempts by other users fail.

SO the First-come-first-serve behavior continues. Even after server reboot.

I found that the issue dont happens on the version 3.8.1, but 3.8.2 it happens and don’t stop.
I think that is related to the Electron update. We will be investigating with the ElectronJS maintainers the issue.


Thank you. If you need anything from my side, please let me know.

Related issue was opened:

Please test the 3.8.6 version if it solves the problem.

This worked, our end users can use the program as expected.