Issues with an existing rocket chat installation

Description

I set up a rocketchat instance on an AWS ec2 instance and it was running fine for the last few months. I had to reboot the server today and when I did and restarted the docker instance it started throwing bad gateway errors the logs were throwing up the following errors in a loop. I thought its an issue with the certificate but I haven’t updated the certificate and it is still valid. I tried updating the docker container version to latest and that didn’t help either.

LocalStore: store created at
rocketchat_1 | LocalStore: store created at
rocketchat_1 | LocalStore: store created at
rocketchat_1 | Error occurred: Error: self signed certificate
rocketchat_1 | at TLSSocket.onConnectSecure (_tls_wrap.js:1515:34)
rocketchat_1 | at TLSSocket.emit (events.js:400:28)
rocketchat_1 | at TLSSocket.emit (domain.js:475:12)
rocketchat_1 | at TLSSocket._finishInit (_tls_wrap.js:937:8)
rocketchat_1 | at TLSWrap.ssl.onhandshakedone (_tls_wrap.js:709:12)
rocketchat_1 | at TLSWrap.callbackTrampoline (internal/async_hooks.js:130:17)
rocketchat_1 | at Socket.ondata (internal/js_stream_socket.js:77:22)
rocketchat_1 | at Socket.emit (events.js:400:28)
rocketchat_1 | at Socket.emit (domain.js:475:12)
rocketchat_1 | at addChunk (internal/streams/readable.js:293:12)
rocketchat_1 | at readableAddChunk (internal/streams/readable.js:267:9)
rocketchat_1 | at Socket.Readable.push (internal/streams/readable.js:206:10)
rocketchat_1 | at TCP.onStreamRead (internal/stream_base_commons.js:188:23)
rocketchat_1 | at TCP.callbackTrampoline (internal/async_hooks.js:130:17) {
rocketchat_1 | code: ‘DEPTH_ZERO_SELF_SIGNED_CERT’,
rocketchat_1 | source: ‘socket’
rocketchat_1 | }
rocketchat_1 | meteor://:computer:app/app/app.js:206752
rocketchat_1 | throw err;

Server Setup Information

  • Version of Rocket.Chat Server: 4.7.4
  • Operating System: Ubuntu 20.04.4 LTS
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version: 4.0
  • Proxy: Nginx
  • Firewalls involved:

Any additional Information

this is the relevant portion of the docker file. Mongo is working fine and have checked it separately.

version: ‘2’

services:
rocketchat:
image: rocketchat/rocket.chat:4.7.4
command: >
bash -c
“for i in seq 1 30; do
node main.js &&
s=$$? && break || s=$$?;
echo “Tried $$i times. Waiting 5 secs…”;
sleep 5;
done; (exit $$s)”
restart: unless-stopped
volumes:
- ./uploads:/app/uploads
environment:
- PORT=3000
- ROOT_URL=https://rocketchat.inforvio.in
- MONGO_URL=mongodb://mongo:27017/rocketchat
- MONGO_OPLOG_URL=mongodb://mongo:27017/local

 depends_on:
   - mongo
 ports:
   - 3000:3000