The Great Open Source Debate with Elastic, Gluu and GitHub ๐ŸŽค Oct 26

GitHub/GitLab Webhooks Failing in Rocket.chat 4.0.0 (docker)

Description

Greetings. We have updated rocket.chat from 2.1.1 to 4.0.0 via 3.1.1. The migration went well, the only feature currently not working (which did before) are our Github and Gitlab webhooks.

Server Setup Information

  • Version of Rocket.Chat Server: 4.0.0 (via docker)
  • Operating System: linux
  • Deployment Method: docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog: -
  • NodeJS Version: 12.22.1 - x64
  • MongoDB Version: 4.0.27
  • Proxy: apache
  • Firewalls involved: -

Any additional Information

What I am seeing in the logs is the following, however I am certain if this is directly related.

Compiling undefined with meteor-babel without a cache
[object Object]
    at Object.exports.compile (/app/bundle/programs/server/npm/node_modules/meteor/babel-compiler/node_modules/meteor-babel/index.js:78:15)
    at Object.compile (packages/babel-compiler.js:44:29)
    at MethodInvocation.updateIncomingIntegration (app/integrations/server/methods/incoming/updateIncomingIntegration.js:44:40)
    at MethodInvocation.methodsMap.<computed> (app/lib/server/lib/debug.js:66:34)
    at maybeAuditArgumentChecks (packages/ddp-server/livedata_server.js:1771:12)
    at packages/ddp-server/livedata_server.js:719:19
    at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1234:12)
    at packages/ddp-server/livedata_server.js:717:46
    at Meteor.EnvironmentVariable.EVp.withValue (packages/meteor.js:1234:12)
    at packages/ddp-server/livedata_server.js:715:46
    at new Promise (<anonymous>)
    at Session.method (packages/ddp-server/livedata_server.js:689:23)
    at packages/ddp-server/livedata_server.js:559:43

Hi,
Maybe related with this change [BREAK] Webhook will fail if user is not part of the channel by sampaiodiego ยท Pull Request #23310 ยท RocketChat/Rocket.Chat ยท GitHub ?

Hi @emikolajczak , thank you. I updated to 4.0.1 but it didnโ€™t help. Are github hooks working for you? I set up a new webhook and tried again without success โ€ฆ do you have any further ideas?

Hard to say, I still not upgraded to 4.x.x

@timmccauley make sure content-type is set to application/json for those requests.

2 Likes

Hi @debdut.chakraborty - many thanks. It works like a charm.

2 Likes