Docker deployment failed with Mongodb refusing to start (Restarting 132)


On a brand new Ubuntu 22.04, I’m trying to deploy server, but MongoDB refuse to start.
docker ps -a

bitnami/mongodb:5.0 “/opt/bitnami/script…” About a minute ago Restarting (132)

Tried a few things, but no way to make this container start.
I followed this tutorial:

Is there something missing about how to make MongoDB start ?

Server Setup Information

  • Version of Rocket.Chat Server: 6.4.0
  • Operating System: Ubuntu 22.04
  • Deployment Method: Docker
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version: 5.0
  • Proxy: no proxy
  • Firewalls involved: no firewall

Any additional Information “docker-entrypoint.s…” About a minute ago Up 1 second>3000/tcp rchat-rocketchat-1

bitnami/mongodb:5.0 “/opt/bitnami/script…” About a minute ago Restarting (132) 41 seconds ago rchat-mongodb-1

Solved. The VPS didn’t had the avx / avx2 instructions activated.

I had tons of trouble to find the error, it wasn’t displayed until I tried the snap version.

Best regards