Disable login screen

hello everyone
When I was doing some settings, the login screen was disabled in the system
(login name-password no longer appears) but login through cmd successfully. The question is how can I reset the login screen settings

Server Setup Information:
Operating System: Ubuntu
Rocket.Chat Server

Screenshot login

Hi @AbdullahAmmar ! Welcome to our community! :hugs:

You probably changed this setting:

Workspace > Settings > Layout > Login > Show Default Login Form

Let me know if this helps :slight_smile:


Thank you @dudanogueira
I’m a new user of rocket chat, the problem was how can access the administrator setting because the login field is disabled

Ah, ok :slight_smile:

As I don’t know how you have deployed, here is the steps for a docker deployment (consider you are using the oficial docker compose)

docker compose exec mongodb mongo
rs0:PRIMARY> use rocketchat
switched to db rocketchat
rs0:PRIMARY> db.rocketchat_settings.update({"_id": "Accounts_ShowFormLogin"}, {$set: {'value': true}})
WriteResult({ "nMatched" : 1, "nUpserted" : 0, "nModified" : 0 }

Another way you could solve this, is logging in and change the settings using the APIs :slight_smile:

let me know if that helps :slight_smile: