Can't send broadcast E-Mails

Hello together,

actually i have the problem that my Rocket Chat Server can’t send Broadcast E-Mails like password reset mails. I searched a bit and found maybe two solutions.

SMTP Verification Emails not working - tried the same like in this post but i could’t change the index.js because its read only and i can’t remount the file system to rw. I always get this error: mount: /snap/rocketchat-server/1597: cannot remount /dev/loop6 read-write, is write-protected.

In the same thread is another solution but honestly i am to rookie to understand how to solve the problem.

Thanks in advance for your help

Server Setup Information

  • Version of Rocket.Chat Server: 6.5.0
  • Operating System: Ubuntu 20.04.6 LTS
  • Deployment Method: snap
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: v14.21.2
  • MongoDB Version: 5.0.15 / wiredTiger
  • Proxy: none
  • Firewalls involved: ufw

Any additional Information

log entry: “name”:“System”,“err”:{“type”:“Error”,“message”:“Greeting never received”,“stack”:“Error: Greeting never received
at SMTPConnection._formatError (/snap/rocketchat-server/1597/programs/server/npm/node_modules/meteor/email/node_modules/nodemailer/lib/smtp-connection/index.js:784:19)
at SMTPConnection._onError (/snap/rocketchat-server/1597/programs/server/npm/node_modules/meteor/email/node_modules/nodemailer/lib/smtp-connection/index.js:770:20)
at Timeout. (/snap/rocketchat-server/1597/programs/server/npm/node_modules/meteor/email/node_modules/nodemailer/lib/smtp-connection/index.js:704:22)
at listOnTimeout (internal/timers.js:557:17)
at processTimers (internal/timers.js:500:7)
=> awaited here:
at Function.Promise.await (/snap/rocketchat-server/1597/programs/server/npm/node_modules/meteor/promise/node_modules/meteor-promise/promise_server.js:56:12)
at Object.Email.send (packages/email/email.js:250:18)
at AccountsServer.Accounts.sendResetPasswordEmail (packages/accounts-password/password_server.js:540:9)
at server/methods/sendForgotPasswordEmail.ts:36:13
at /snap/rocketchat-server/1597/programs/server/npm/node_modules/meteor/promise/node_modules/meteor-promise/fiber_pool.js:43:40”,“code”:“ETIMEDOUT”,“command”:“CONN”},“msg”:“Greeting never received”}

Please Someone Answe This,
I’m also facing the issue,
I installed in AWS EC2 using docker
I also get the same error

I found my problem. I was thinking i had to set the protocol in the E-Mail settings to smtp because the port from my mail client was marked as port for smtp. But it was smtps… after the change it worked directly