Can't restore snap after automatic 2.4.12 update



Yesterday trying to resolve the problem of the automatic update (2.4.11 to 2.4.12), I removed and saved a rocket chat snap. When I run sudo snap saved I can see my snapshot:


However when I try to restore it with sudo snap restore 1 after ~15 minutes it displays Restored snapshot #1 and the folder /var/snap/rocketchat-server is created with content inside. The problem is that it seems it is not installed.

Running sudo snap list prints only the core:

Name  Version    Rev   Tracking       Publisher   Notes
core  16-2.44.3  9066  latest/stable  canonical✓  core

Is there a extra step or parameter I need?


Server Setup Information

  • Version of Rocket.Chat Server: 2.4.11 and 2.4.12
  • Operating System: Ubuntu 18.04
  • Deployment Method: snap
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: caddy
  • Firewalls involved:

Any additional Information

I ran snapshot check and it was successful.

my snapchat glitched out and in spite of the fact that me and my companion had unquestionably snapped each other enough for our streak to not end, I saw that our streak had “vanished” or “finished”. I was really disturbed since it was more than 200, so I went on Snapchat’s authentic site (you can’t take care of business inside the application) and rounded out a grumbling. My issue was illuminated that day. Give it a shot, for the most part the main do it if it’s been as of late lost and I heard that in the event that you solicitation to recover your lost streak too often, they won’t do it for you. Good luck.
9Apps Showbox