Can't disconnect from Rocket.Chat Cloud and re-add

I upgraded from 3.4.1 to 3.5, push notifications to iOS devices stopped working. Checked all Push settings, they were working before upgrade. So I figured I would remove the server/workspace from the cloud.rocket.chat site and re-add. Removed, no workspace is listed.

Back in Administration, when I go to Connectivity Services and click the “Disconnect” button, it gives a green Disconnected in top right. Goes back to the Registration Required section with a “Click here to register your workspace.” I receive a red “Error occurred syncing” in top right.

Linux Console/syslog Says: “nodejs[31279]: Failed to get AccessToken from Rocket.Chat Cloud. Error: oauth_unable_to_find_workspace”

I appears to be stuck in a loop. Start/Stopped the Rocket Chat Server Service. No help.

On the Connectivity Service page. Clicking on the “Login to Rocket.Chat Cloud” button opens a login page, when I put in my creds it just loops back to login, does not login. (I know the account works as I can go to the site directly and login) I tried Administration from Web or Client, same result. On a Client I have to remove Server or I can’t get back in, stuck on Rocket.Chat Cloud login.

How can I remove and re-add server/workspace?

  • Version of Rocket.Chat Server: 3.5.0
  • Operating System: Ubuntu 18.04
  • Deployment Method: tar
  • Number of Running Instances: 1
  • DB Replicaset Oplog: Enabled
  • NodeJS Version: 12.18.3
  • MongoDB Version: 3.6.3
  • Proxy: apache
  • Firewalls involved: No
1 Like

Hello! I have a same problem . But i have rocketchat version 3.0.4 . I think need delete connect settings in mongodb , but i not found this settings((

I’m stuck. Does anyone know how to get out of this loop? How does one reset or clear the Connect Services? I can not find this in docs or via google foo.

I hope this helps you… But for me, it was removing the Rocket Chat instance from their end https://cloud.rocket.chat/ and re-register/resync from scratch.

I had to find the : more button on the right and select Remove/Delete workspace (which is hard to find!).

After that’s cleared out, I tried adding my instance to their https://cloud.rocket.chat/ and resync. Seemed to come back OK.

Good luck!