Can't activate or reset password or set new password

I’m just trying to login to the community chat server, but nothing is working. I received the confirmation email just fine for the forums, but nothing from the chat server. I then tried to login with github with the same email on that account and now I’m greeted with:

“This email has already been used and has not been verified. Please change your password.” and “Type your new password”.

But no matter what password I type. I get: “Error” and then “Entered password same as current password [error-password-same-as-current]” but I’m using a password generator and I tried several random passwords and I get the same error every time??

So I can’t activate, I can’t login, and when I do, I can’t reset.

What is happening?

We receive a lot of spam registrations and have a bounce handler that a bit too aggressively cuts off email to prevent our account from getting shut down.

Should be back on

Thanks. I’m still stuck on this page though? No matter what I type I get the same error.