Can't create rocket.chat Cloud Account

Hi, just trying to create an account on https://cloud.rocket.chat/register and it always fails. Request id: 1dcee0ba-f067-422a-bc9f-1a129e22a31a

This shouldn’t have anything to do with my rocket.chat installation, right?

Cheers, Joshua

Same story.
Even support can’t do anything. Rocket chat cloud is a failure. And they are forcing everyone now for pushes.
I had to turn them off. And block that “cat bot”.

Same issue here, cannot connect with cloud. Doesn’t work.

I also am unable to create an account in order to register my self-hosted server.

@joshxtra Looks like you tried to create an account and your email is already used, might try to request a password reset?

Here’s what our logs show:
1dcee0ba-f067-422a-bc9f-1a129e22a31a: user_email_already_in_use - -- user_email_already_in_use


For everyone else, if you want to try again or reset your password just in case you’re experiencing the same thing go ahead. And if that doesn’t work, post the request id here and I’ll try to figure out what is going wrong. I’ll also work on exposing the actual error since I was under the impression it was already verbose and should have said what was wrong.

Thanks bradley for your reply.
I also suspected the e-mail to already be in use, however i didn’t receive a reset mail when i requested a password reset. I tried again just now and still no e-mail.
Any idea what could be the Problem here?

@joshxtra let me look into it and get back with you. I’ll let you know as soon as I find what’s wrong

1 Like

@joshxtra an update: after looking into the code, it intentionally avoids sending out password reset emails if an email is not verified. I’m working on fix for this as that logic doesn’t make sense to me. If an email is not verified, we should still allow people to reset their password and upon successfully resetting their password mark their email as verified. The fix should be done shortly but I will need to wait for it to be deployed which should happen before the end of the day today.

1 Like

@joshxtra the fix has been deployed. If you don’t mind, can you try again and let me know if you get it or not?

1 Like

@bradley.hilton thanks, that did it!
Does the Account now count as verified though? I can’t find any Method to check in the UI.
Also, I can’t find a way to generate an API Token to paste in my rocket.chat installation.

Edit: I could now login to RC Cloud from within our installation and was able to download from the Marketplace. The Workspace that it created, however has the Name “your Workspace” and the Adress “https://your-workspace-address”. Is that a Problem?

Thanks again for the help!

@joshxtra fantastic, glad to hear that! :clap:

That shouldn’t be a problem, however, if you want to see updated information then you can click the button “sync” inside of Rocket.Chat and you should see that information update inside of Rocket.Chat Cloud.

2 Likes

Thanks again @bradley.hilton sync worked.
One last thing: How can i delete a workspace? There is an orphaned workspace that was probably created at some point during the first registration of the cloud account. The two workspaces now have the exact same names and data, i want to delete one of them.

@joshxtra I just realized I never got back to you. We deployed the ability to remove a workspace yesterday, so you should be able to do it now.

1 Like

Thanks @bradley.hilton!

It’s all perfect now :slight_smile:

2 Likes

This doesn’t seem fixed to me.
I clicked Forgot Password, then received the email.
However, when I click the link, all that comes up on the rocket chat webpage is some text saying “Reset your password”… nothing to click on, or type in to.

Please help me!!

Please read the text in the warning. You need to accept the Terms Agreement under: Setup Wizard -> Cloud Info -> Cloud Service Privacy Terms Agreement.

I’m attempting to log into the RocketChat Cloud to manage integration with my on-prem server. I’m doing so with the Admin -> Marketplace -> Login button. I get the RC Cloud login window, enter my known valid creds (i’ve tested from the website) and I’m immediately returned to the login prompt.