Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

Cannot send *.cdr files

Description

After upgrade to 3.18.0 we are unable to send *.cdr files - it fails with “Media Type Not Accepted: undefined” error. We do not block any types of media (even SVG). How can i allow undefined media or make rocket chat recognize cdr files?

Server Setup Information

  • Version of Rocket.Chat Server: 3.18.0
  • Operating System: CentOS Linux
  • Deployment Method: tar
  • Number of Running Instances: 1
1 Like

Welcome @MoonWolf !

Are those Corel Draw files? It is not easy for any of us to generate those files. Might you be able to upload a couple of small samples?

Confirm. After updating to version 3.18.0, a similar problem appeared. This type of media : undefined. The problem appears with extensions of various non-common types. CorelDRAW , Autocad, SolidWorks, .reg, and others. on version 3.17.2, it worked without problems.

Please, dear developers, pay attention to this problem, everything worked exactly on 3.17.2. There was a problem after updating to version 3.18.0. I wanted to make a downgrade from 3.18.0 to. 3. 17. 2, but it didn’t work out . The application writes active in the services, but instead of a chat, I get an Nginx window. Instructions Updating - Rocket.Chat Docs from here. In the curl-L line https://releases.rocket.chat/latest/download -o /tmp/socket. chat. tgz I write 3.17.2 instead of latest, but it doesn’t work. What am I doing wrong? At the moment, I have 2 ways, either wait for an update with a fixed download problem or downgrade to version 3.17.2, when everything worked. Help! Sorry, bad translate, am Russian)

Hello all

Yes, those are Corel Draw files. Sorry, but I don’t know how to upload them here (cdr files are not authorized).

It almost certainly never will work with a downgrade.

There are often changes to the database structure between versions so your only recourse is to your latest backup and restore from there.

Just paste a google docs, dropbox or other type of link.

You might be able to rename it to say “MyCDRFile.cdr.txt” and upload but I am not sure.

I’ve sent two example files here: Gofile - Free file sharing and storage platform.

did you manage to fix it somehow?

Still waiting for devs to fix it. And as I still don’t know how LDAP will behave in 4.0 in our case, I’m looking for an alternatives, so this issue isn’t a high priority now.

Hi, I have a cdr file here, and when trying to guess the mimetype, it shows:

$ file --mime-type ‘file.cdr’
file.cdr: application/zip

it’s also the same mime type of a proper .zip file

I was able to upload the .zip file, but not the .cdr file (using 4.0.0, test at 3.18.1 and same results)

I think this is more at the interface level. There were no server calls at all (rest nor websocket)

One thing to note:
I added image/jpeg to the forbidden upload mimes, and it successfully showed it was not allowed.

When I tried the .cdr file, it gives a toast message with undefined mimetype:

Tipo de Mídia não aceito: undefined

Sing had some comments on this in a channel on open - have a word with him about it.

Please write how you will be able to solve this problem and unsubscribe the solution to this topic. I’m really looking forward to the decision. Thanks.