Rocket.Chat's Community Open Call 🎤 Dec 15, 2021 Join us!

Wrong IP Server

Description

Hi,

I have a problem with configuring RocketChat & snap.

RC is installed with snap. When I use the command “snap set rocketchat-server caddy-url = https myRC.com”, I get the error “Your public IP doesn’t match the one resolved for caddy-url, disabling https”.

I noticed in the code that RC uses the command “curl ipinfo.io/ip” in order to find the IP of the server. But on my server, the IP of our proxy servers is found. So I have to configure RC with “caddy-url = https /myPROXY.com” for it to work, and then change the url in the desktop app settings. But I have to do it regularly because the proxy url reconfigures itself automatically.

How to fix this? Can developers change the way to retrieve the server name based on the name (like
a good old nslookup command ^^)

Thanks for your help :wink:

Server Setup Information

  • Version of Rocket.Chat Server: 3.18.3
  • Operating System: Debian 10
  • Deployment Method: snap 16-2.53.2