Snap is not obeing caddy variable and is starting it when set to disable

Server Setup Information

  • Version of Rocket.Chat Server: 6.7.1 and 6.8.0
  • Operating System: debian bullseye
  • Deployment Method: snap
  • Firewalls involved: none

caddy2 is started no mater if i set snap variable to disable or if I disable snap.rocketchat-server.rocketchat-server-caddy.service

We need to see what you are doing.

Can you show how you disable it please?

Commands, configs, logs etc.

Well, obviously i have to stop it manually after setting caddy=disable. Me bad sorry.

And after machine reboot caddy is starting again

#lsof -Pni
caddy2  1009 root    3u  IPv6  17738      0t0  TCP *:3000 (LISTEN)
caddy2  1009 root    7u  IPv6  17741      0t0  TCP *:80 (LISTEN)


Also note my comments in your other thread.

You are likely wasting your time with snaps. They are too inflexible for your requirements.

Use docker for Rocket, Mongo, and your own proxy eg Nginx or Apache.

Following this

# snap get rocketchat-server 
Key                Value
backup-on-refresh  disable
caddy              disable
ignore-errors      false
mongo-oplog-url    mongodb://localhost:27017/local
mongo-url          mongodb://localhost:27017/parties
port               3000
siteurl            http://localhost:3000
# systemctl status snap.rocketchat-server.rocketchat-caddy.service 
● snap.rocketchat-server.rocketchat-caddy.service - Service for snap application rocketchat-server.rocketchat-caddy
    Loaded: loaded (/etc/systemd/system/snap.rocketchat-server.rocketchat-caddy.service; disabled; vendor preset: enabled)
#lsof -Pni
caddy2  1009 root    3u  IPv6  17738      0t0  TCP *:3000 (LISTEN)
caddy2  1009 root    7u  IPv6  17741      0t0  TCP *:80 (LISTEN)

I don’t see a key for “caddy disable” in the docs.

I’ll ask the person who builds them.