SAML Metadata after hostname change


I have installed Rocket.Chat on a Centos 8.1 VM and had SAML authentication working with ADFS. Then, I moved my server from the test vlan to production and changed the hostname. Now, in my SAML metadata (and in my SAML requests) the fields for binding are using the old hostname. How can I fix this? “Binding=“urn:oasis:names:tc:SAML:2.0:bindings:HTTP-POST” Location=”//"

Please help.

Server Setup Information

  • Version of Rocket.Chat Server: 3.0.6
  • Operating System: CentOS Linux release 8.1
  • Deployment Method: /docs/installation/manual-installation/centos/
  • Number of Running Instances: 1
  • DB Replicaset Oplog:
  • NodeJS Version: 12.14.0
  • MongoDB Version: 4.0.17
  • Proxy: nginx
  • Firewalls involved: firewalld 0.7.0

Any additional Information

Old hostname was “” but changed it to “” and moved to new subnet. Have tried:
I have updated the hostname of the server.

  • Updated in DNS.
  • Updated /usr/lib/systemd/system/rocketchat.service, daemon-reload, and restart services.
  • Updated my nginx config files for the site.
  • Tried to find any mention of the old hostname in the mongo database (although I’m not very familiar with MongoDB, so I could have missed something).

I neglected to change the site URL on the settings tab, and couldn’t find it in mongo (and it didn’t update from the rocketchat.service file). I have corrected this. Now, I just need to figure out why SAML users aren’t being created…