One user cannot connect due to rate limit


One of our user is unable to connect to rocket due to rate-limit.
The logs show a connexion than :
avril 05 08:43:56 rocket rocketchat-server.rocketchat-server[11141]: {“level”:35,“time”:“2024-04-05T06:43:56.533Z”,“pid”:11215,“hostname”:“rocket”,“name”:“API”,“method”:“POST”,“url”:“/api/v1/”,“userId”:“YEWg3ifN6Ar6cafMa”,“userAgent”:"Mozilla/5.0 (X1\

1; Ubuntu; Linux x86_64; rv:124.0) Gecko/20100101 Firefox/124.0",“length”:“97”,“host”:“”,“referer”:“Rocket Bordeaux INP”:3}

avril 05 08:43:56 rocket rocketchat-server.rocketchat-server[11141]: {“level”:30,“time”:“2024-04-05T06:43:56.764Z”,“pid”:11215,“hostname”:“rocket”,“name”:“RateLimiter”,“msg”:“limit by connectionId per method”,“reply”:{“allowed”:false,“timeToReset”:38983,“numInvocationsLeft”:0,"numI\


I have disabled rate-limit in the admin panel but it does not change behavior…
I have restarted the snap instance but it does not change anything

Server Setup Information

  • Version of Rocket.Chat Server: Version 6.6.2
  • Operating System: ubuntu 22
  • Deployment Method: snap
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version:
  • MongoDB Version:
  • Proxy: -caddy
  • Firewalls involved:

Any additional Information

Have you disabled (or adjusted) the DDP rate limits (Settings/Rate Limits) ?
If you have then try disabling them?
Have you tried the latest version? (will be a requirements for the next step)
If even with disabled, then raise a bug on Rocket’s Git page because they don’t spend time here.

Good Luck

Thanks for the answer,

I have disabled it in the pannel settings → rate limiter

I have tried several tuning, increasing the number of calls… what is strange is that only one user is in concern. I have given a look on her record on mongodb and nothing special…

I have not yet upgraded to the last version (I’m puzzled, since we have a subscription, it I thought update was done automatically)

If you’re paying Rocket.Chat for a subscription, then don’t waste time in these forums, they aren’t visited by employees, head over to and raise a ticket.

1 Like

Yes… I understand, but sometimes community has the answer quicker than the support… if somebody has had the same problem. I have an open ticket (and still waiting)…

Ok then, another reason not to pay a subscription then, I had envisaged a degree of support.

And I was thinking about this, only affecting one user, which is strange.

Looking at the Log, the user is connecting with a Mozilla browser (or another browser pretending to be) is that correct? have they tried another browser (I’m thinking plugins here that could interfere with the clientside code)

And is there anything strange about that one user’s configuration in Mongo? db.users.find(… etc)?

Well, I have had answers from the support today.
The problem seems to be with the number of seats that seems to be limited to 400, but we should have 700 more… b

About browser and plugin, yes we have tried, and the problem is that, for example, I can log in as an admin on my usual browser, but not with a new one…
I think I need to raise the number of seats allowed, but I can’t find where…