Omnichannel Business Hours

Even though my timezone setting is set correctly and the time appears correct in logs (includes timezone there) business hours don’t seem to work correctly. I cannot just use UTC as it would span midnight and it looks like we can only include a single time business time per day now. I also wish that was not the case as out sales and support are open different hours.

Version
3.14.3

Hi, please upgrade to 3.14.4 - see the release notes for details.

I have feeling this issue might have been fixed in 3.15 but I can’t see it, Again please check the release notes.

I am already at 3.15

Can you try and explain your issue in a little more depth please - with some examples?

Sure. The options for hours in “business hours” are pick the days you want to have business hours and a time span those days you want to be open. That has the flaw in that it would not allow business hours that span midnight or have two periods of open during the same day. Additionally all departments now have to have the same hours. I don’t think that is how it used to be.

Additionally, at least on my server, the time appears correct. At least in the logs that you see in RC admin area are TZ corrected to the right time. However, when I set business hours, it actually seems to be about four hours off. Which does coincide with Atlantic time (where your DEV offices are)

OK - that looks like a potential bug.

Hmmm - that I don’t understand. Our devs are all over the place :laughing:

You should be able to set the server time to whatever you want.

What sort of install have you got?

Sorry, you requested I upgrade to 3.15 for another question and I didn’t check this issue after. Looks like the time being off was fixed in 3.15.

So, just looks like the limited settings for business hours and only being able to set them universally is the only issue left. on this one.

Cool!! One down then.

OK. Let me know where you are at with this.