Rocket.Chat's Community Open Call 🎤 Jan 19th, 2022 Join us!

MongoDB Atlas Dedicated cluster

Hello. My problem is that when I switch to a dedicated cluster it stops working. That is, in the shared cluster it comes out:

ReplicaSet OpLog: Enabled
In the dedicated cluster it comes out: ReplicaSet OpLog: Disabled

As you know, it needs to be up for Rocket.Cat to start, the log says. I use Ubuntu 18.04, manual installation.

Change Stream is available for your installation, give admin permissions to your database user to use this improved version.
not authorized on local to execute command { find: “oplog.rs”, filter: {}, sort: { $natural: -1 }, projection: { _id: 0, ts: 1 },

±--------------------------------------------------------------------------+
| SERVER ERROR |
±--------------------------------------------------------------------------+

| Rocket.Chat Version: 4.2.0 |
| NodeJS Version: 12.18.4 - x64 |
| MongoDB Version: 4.4.10 |
| MongoDB Engine: unknown |
| Platform: linux |
| Process Port: 3000 |
| ReplicaSet OpLog: Disabled |
| OPLOG / REPLICASET IS REQUIRED TO RUN ROCKET.CHAT, MORE INFORMATION AT: |
| Configure a replica set for MongoDB - Rocket.Chat Docs |

Both connect perfectly, as I said … it only stops working on the dedicated, not on the shared.