Centos "try install out" fails in browser times out


#1

Hi! … limited experience with linux
have vps with minimal centos 7 install
1GB 1core 40GB
[root@localhost Rocket.Chat]# node main.js
Updating process.env.MAIL_URL
Starting Email Intercepter…
LocalStore: store created at
LocalStore: store created at
LocalStore: store created at
Warning: connect.session() MemoryStore is not
designed for a production environment, as it will leak
memory, and will not scale past a single process.
Setting default file store to GridFS
LocalStore: store created at
LocalStore: store created at
LocalStore: store created at
connect deprecated multipart: use parser (multiparty, busboy, formidable) npm module instead npm/node_modules/connect/lib/middleware/bodyParser.js:56:20
connect deprecated limit: Restrict request size at location of read npm/node_modules/connect/lib/middleware/multipart.js:86:15
{“line”:“158”,“file”:“rocketchat_migrations.js”,“message”:“Migrations: Not migrating, already at version 131”,“time”:{"$date":1537973494668},“level”:“info”}
Updating process.env.MAIL_URL
Using GridFS for custom sounds storage
Using GridFS for custom emoji storage
➔ System ➔ startup
➔ ±------------------------------------------------+
➔ | SERVER RUNNING |
➔ ±------------------------------------------------+
➔ | |
➔ | Rocket.Chat Version: 0.69.2 |
➔ | NodeJS Version: 8.9.3 - x64 |
➔ | Platform: linux |
➔ | Process Port: 3000 |
➔ | Site URL: http://myipaddress!!:3000/ |
➔ | ReplicaSet OpLog: Disabled |
➔ | Commit Hash: 7df9818105 |
➔ | Commit Branch: HEAD |
➔ | |
➔ ±------------------------------------------------+

when i then open a browser and
http://myipaddress:3000
it just times out
Anything obvious that i am missing?
thanks for any responses :slight_smile: smile:

don’t know if this helps
taken from monodb log
2018-09-26T14:32:20.640+0000 I CONTROL [main] ***** SERVER RESTARTED *****
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] MongoDB starting : pid=1851 port=27017 dbpath=/var/lib/mongo 64-bit host=localhost
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] db version v3.6.8
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] git version: 6bc9ed599c3fa164703346a22bad17e33fa913e4
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] OpenSSL version: OpenSSL 1.0.1e-fips 11 Feb 2013
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] allocator: tcmalloc
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] modules: none
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] build environment:
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] distmod: rhel70
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] distarch: x86_64
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] target_arch: x86_64
2018-09-26T14:32:20.833+0000 I CONTROL [initandlisten] options: { config: “/etc/mongod.conf”, net: { bindIp: “127.0.0.1”, port: 27017 }, processManagement: { fork: true, pidFilePath: “/var/run/mongodb/mongod.pid”, timeZoneInfo: “/usr/share/zoneinfo” }, storage: { dbPath: “/var/lib/mongo”, journal: { enabled: true } }, systemLog: { destination: “file”, logAppend: true, path: “/var/log/mongodb/mongod.log” } }
2018-09-26T14:32:20.833+0000 I STORAGE [initandlisten] wiredtiger_open config: create,cache_size=256M,session_max=20000,eviction=(threads_min=4,threads_max=4),config_base=false,statistics=(fast),cache_cursors=false,compatibility=(release=“3.0”,require_max=“3.0”),log=(enabled=true,archive=true,path=journal,compressor=snappy),file_manager=(close_idle_time=100000),statistics_log=(wait=0),verbose=(recovery_progress),
2018-09-26T14:32:21.476+0000 I STORAGE [initandlisten] WiredTiger message [1537972341:476616][1851:0x7f2669329b00], txn-recover: Set global recovery timestamp: 0
2018-09-26T14:32:21.490+0000 I CONTROL [initandlisten]
2018-09-26T14:32:21.490+0000 I CONTROL [initandlisten] ** WARNING: Access control is not enabled for the database.
2018-09-26T14:32:21.490+0000 I CONTROL [initandlisten] ** Read and write access to data and configuration is unrestricted.
2018-09-26T14:32:21.490+0000 I CONTROL [initandlisten]
2018-09-26T14:32:21.491+0000 I STORAGE [initandlisten] createCollection: admin.system.version with provided UUID: 414ddce5-bdde-44f1-a2d6-0e3677e9b28b
2018-09-26T14:32:21.497+0000 I COMMAND [initandlisten] setting featureCompatibilityVersion to 3.6
2018-09-26T14:32:21.501+0000 I STORAGE [initandlisten] createCollection: local.startup_log with generated UUID: c74af861-3c2a-48cb-a3c0-a30abf67ee4c
2018-09-26T14:32:21.507+0000 I FTDC [initandlisten] Initializing full-time diagnostic data capture with directory ‘/var/lib/mongo/diagnostic.data’
2018-09-26T14:32:21.507+0000 I NETWORK [initandlisten] waiting for connections on port 27017
2018-09-26T14:32:21.513+0000 I STORAGE [LogicalSessionCacheRefresh] createCollection: config.system.sessions with generated UUID: 4904c6a6-3f74-4a0d-b6bd-c3a393715f15
2018-09-26T14:32:21.522+0000 I INDEX [LogicalSessionCacheRefresh] build index on: config.system.sessions properties: { v: 2, key: { lastUse: 1 }, name: “lsidTTLIndex”, ns: “config.system.sessions”, expireAfterSeconds: 1800 }
2018-09-26T14:32:21.522+0000 I INDEX [LogicalSessionCacheRefresh] building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2018-09-26T14:32:21.523+0000 I INDEX [LogicalSessionCacheRefresh] build index done. scanned 0 total records. 0 secs
2018-09-26T14:32:27.993+0000 I NETWORK [listener] connection accepted from 127.0.0.1:44268 #1 (1 connection now open)
2018-09-26T14:32:27.993+0000 I NETWORK [conn1] received client metadata from 127.0.0.1:44268 conn1: { driver: { name: “nodejs”, version: “2.2.34” }, os: { type: “Linux”, name: “linux”, architecture: “x64”, version: “3.10.0-862.11.6.el7.x86_64” }, platform: “Node.js v8.9.3, LE, mongodb-core: 2.1.18” }
2018-09-26T14:32:28.007+0000 I STORAGE [conn1] createCollection: rocketchat.users with generated UUID: 80d56341-bd0e-427c-a631-072644776d8c
2018-09-26T14:32:28.019+0000 I INDEX [conn1] build index on: rocketchat.users properties: { v: 2, unique: true, key: { username: 1 }, name: “username_1”, ns: “rocketchat.users”, sparse: 1 }
2018-09-26T14:32:28.019+0000 I INDEX [conn1] building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2018-09-26T14:32:28.020+0000 I INDEX [conn1] build index done. scanned 0 total records. 0 secs
2018-09-26T14:32:28.025+0000 I INDEX [conn1] build index on: rocketchat.users properties: { v: 2, unique: true, key: { emails.address: 1 }, name: “emails.address_1”, ns: “rocketchat.users”, sparse: 1 }
2018-09-26T14:32:28.025+0000 I INDEX [conn1] building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2018-09-26T14:32:28.026+0000 I INDEX [conn1] build index done. scanned 0 total records. 0 secs
2018-09-26T14:32:28.031+0000 I INDEX [conn1] build index on: rocketchat.users properties: { v: 2, unique: true, key: { services.resume.loginTokens.hashedToken: 1 }, name: “services.resume.loginTokens.hashedToken_1”, ns: “rocketchat.users”, sparse: 1 }
2018-09-26T14:32:28.031+0000 I INDEX [conn1] building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2018-09-26T14:32:28.032+0000 I INDEX [conn1] build index done. scanned 0 total records. 0 secs
2018-09-26T14:32:28.036+0000 I INDEX [conn1] build index on: rocketchat.users properties: { v: 2, unique: true, key: { services.resume.loginTokens.token: 1 }, name: “services.resume.loginTokens.token_1”, ns: “rocketchat.users”, sparse: 1 }
2018-09-26T14:32:28.036+0000 I INDEX [conn1] building index using bulk method; build may temporarily use up to 500 megabytes of RAM
2018-09-26T14:32:28.037+0000 I INDEX [conn1] build index done. scanned 0 total records. 0 secs


#2

SOLVED … turns out the company supplying the VPS had their own firewall on it … so had to allow port 3000


#3

Would put a reverse proxy in front, nginx or apache.