Can't add bad words to blacklist

Description

Hello!

I am not a programmer or engineer so please forgive my lack of understanding or knowledge. I’m part of a nonprofit org that uses Rocket Chat server to host support chat rooms for youth. I’m trying to add bad words to the blacklist under Admin-Settings-Message but it seems to be not working. I added a bunch of bad words, separated by comma (example: fuck, fucking, shit), and saved changes. I tried testing it in both private and public channel using a test user account but the words still appear unfiltered. This used to work a while ago, the words used to have * as filter so it would show up at as ****. Am I doing something wrong? Is there another setting that I need to turn on/off? Any guidance would be greatly appreciated!

Thank you.

Server Setup Information

  • Version of Rocket.Chat Server: 5.2.0
  • Operating System: Windows 10
  • Deployment Method:
  • Number of Running Instances:
  • DB Replicaset Oplog:
  • NodeJS Version: 14.19.3
  • MongoDB Version: 4.2.8
  • Proxy:
  • Firewalls involved:

Any additional Information

hi @euanlgbtcenters !

Thanks for reaching out!

Indeed, this is a bug. We are refactoring the message parser, the component responsible to show - or not - messages.

if you go, now, to your preferences in Avatar > Preferences > Global and Activate “Use legacy message template”

You will see that it will works properly.

I will open up an issue for that in our Repository

Thanks!

Issue opened:

Hi @dudanogueira

Thanks for the update. I toggled ‘use legacy message template’ and it worked. However, I saw this statement below the toggle: ‘This is a deprecated feature. It may not work as expected and will not get new updates’. Would this cause any issue?

Hi! it will solve your situation for now (notice that it will only change for the current user)

You are enabling the legacy message parser. So soon we should fix all issues we are finding on the new message parser.

However, whatever issues we find on the legacy parser, we will not be fixing, as we are moving forward with the new parser.

You should be fine :slight_smile: