Unable to connect from Mobile Apps

Hi,
because the post related to my issue are more then 1 year old i will open a new thread for this now.
I was not using Rocket.Chat for a while and before, i was running v0.58 and my iOS App was running fine.
Now, some month/years later, i updated to v1.3.1 and the iOS app cannot connect anymore.
My Setup:
Rocket.Chat is running inside a Docker Container on my Synology DS-918+.
Just as well my MongoDB 3.6.9 with replset enabled.
The outgoing port 3000 is not forwarded through the internet, because its behind the synology built in reverse proxy. (https://rocketchat.domain.synology.me)
Rocket.Chat over a Browser is working fine.
SSL is a Lets Encrypt Certificate.

My Reverse Proxy Entry:

server {
    listen 443 ssl;
    listen [::]:443 ssl;

    server_name rocketchat.domain.synology.me;

    ssl_certificate /usr/syno/etc/certificate/ReverseProxy/104a1ff1-d54b-4d32-8897-c08ac4524f0a/fullchain.pem;

    ssl_certificate_key /usr/syno/etc/certificate/ReverseProxy/104a1ff1-d54b-4d32-8897-c08ac4524f0a/privkey.pem;

    location / {

        proxy_connect_timeout 60;

        proxy_read_timeout 60;

        proxy_send_timeout 60;

        proxy_intercept_errors off;

        proxy_http_version 1.1;

        proxy_set_header        Host            $http_host;

        proxy_set_header        X-Real-IP            $remote_addr;

        proxy_set_header        X-Forwarded-For            $proxy_add_x_forwarded_for;

        proxy_set_header        X-Forwarded-Proto            $scheme;

        proxy_pass http://192.168.1.254:3000;

    }

    error_page 403 404 500 502 503 504 @error_page;

    location @error_page {
        root /usr/syno/share/nginx;
        rewrite (.*) /error.html break;
        allow all;
    }

}

if i try to connect from my iOS app with rocketchat.domain.synology.me i got an error:
Could not connect to server …

What could i do? Thank you for your support.

// EDIT:
I got it working. I found a solution to my issue here:

1: Make sure your NAS is running at least DSM version 6.2.1-23824.
2: Go the the reverse proxy settings you have made (look at the earlier posts in this thread), highlight it and click “Edit”.
3: Click the tab “Custom Header”
4: Click the down arrow in the “Create” button".
5: A dropdown will appear with “Websocket”, click it.
6: Two new custom headers will appear automatically, now click “Ok”.
And that’s it!

Thank you