Trying upgrade from 0.74 to 1 / replica

#1

Description

I want to upgrade a running 0.74 without replica/OpLog deactive to newest version.
I proceed as described here.

echo -e "replication:\n replSetName: “rs01"” | sudo tee -a /etc/mongod.conf
sudo systemctl restart mongod
mongo
> rs.initiate()

and expand the Environment Line to:
Environment=MONGO_URL=mongodb://localhost:27017/rocketchat ROOT_URL=http://xxxxx.yyyyyy.zz:3000/ PORT=3000 MONGO_OPLOG_URL=mongodb://localhost:27017/local?replSet=rs01

the mongo-log shows “MongoError: not master and slaveOk=false”, so I have to enter
rs.slaveOk()
in mongo-shell after every boot. The RC service is starting now, but in the client there’s a message “502 bad gateway”

I’m freshly new to RC and have no idea what to do! Any help?

Server Setup Information

  • Version of Rocket.Chat Server: 0.74.3
  • Operating System: Debian 9
  • Deployment Method: manual installation
  • Number of Running Instances: 1
  • DB Replicaset Oplog: deactive
  • NodeJS Version: v8.11.3
  • MongoDB Version: 3.6.11
  • Proxy:
  • Firewalls involved:

Any additional Information

/etc/mongod.conf
# mongod.conf
erence/configuration-options/

# Where and how to store data.
storage:

  • dbPath: /var/lib/mongodb*
  • journal:*
  • enabled: true*
    # engine:
    # mmapv1:
    # wiredTiger:

# where to write logging data.
systemLog:

  • destination: file*
  • logAppend: true*
  • path: /var/log/mongodb/mongod.log*

# network interfaces
net:

  • port: 27017*
  • bindIp: 127.0.0.1*

# how the process runs
processManagement:

  • timeZoneInfo: /usr/share/zoneinfo*
#2

update:
I got RC1.0.3 running with mongo 3.6.12, but it seems that now I need to start the rocketchat service manually after each server restart.
After restarting rocketchat the message
MongoError: not master and slaveOk=false
is still there, but now the service starts.