# RC v7.x to v8.0.1 needing to upgrade MongoDB to v8.2

**URL:** <https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676>\
**Category:** Upgrade Help\
**Created:** [January 15, 2026, 8:06am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676 "2026-01-15T08:06:26Z")\
**Posts on this page:** 12\
**Page:** 1

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [January 15, 2026, 8:06am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/1 "2026-01-15T08:06:26Z")

</div>

## What version are you coming from? 7.13.1

## What version are you going to? 8.0.1

## What deployment method did you use to deploy? Docker

## Did you follow a particular doc? Which one?

## What issues are you running into upgrading? Bitnami/MongoDB v6 no longer supported. MongoDB v8.2 required, but not being pulled.

---

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [January 15, 2026, 8:09am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/2 "2026-01-15T08:09:17Z")

</div>

I have tried to pull the latest MongoDB community server image and use that but get an error in the manifest.

Tried a fresh Docker installation (as our RC deployment is currently a Proof of Concept only), and that seems to install ok, but is still pulling bitnami/mongodb v6.0 and the RC Docker logs are reporting the following:

±----------------------------------------------------------------+  
| SERVER ERROR |  
±----------------------------------------------------------------+  
| |  
| Rocket.Chat Version: 8.0.1 |  
| NodeJS Version: 22.16.0 - x64 |  
| MongoDB Version: 6.0.13 |  
| MongoDB Engine: wiredTiger |  
| Platform: linux |  
| Process Port: 3000 |  
| Site URL: [http://localhost](http://localhost) |  
| Commit Hash: 7137ec80f3 |  
| Commit Branch: HEAD |  
| |  
| YOUR CURRENT MONGODB VERSION IS NOT SUPPORTED BY ROCKET.CHAT, |  
| PLEASE UPGRADE TO VERSION 7.0 OR LATER |  
| |  
±----------------------------------------------------------------+

---

<div class="post-metadata">

**Author:** ![reetp](https://sea1.discourse-cdn.com/flex021/user_avatar/forums.rocket.chat/reetp/32/5546_2.png) [@reetp](https://forums.rocket.chat/u/reetp)\
**Post date:** [January 15, 2026, 6:56pm UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/3 "2026-01-15T18:56:34Z")

</div>

Always search first.

> [@Bitnami Image Removal Impacting Older Helm and Docker Compose Deployments](https://forums.rocket.chat/t/bitnami-image-removal-impacting-older-helm-and-docker-compose-deployments/22551):
>
> Hi everyone, We’d like to inform you about a recent issue affecting some Rocket.Chat self-hosted deployments. Bitnami has removed several of their container images from public repositories (not just deprecated them as we were expecting). This change affects older Helm charts and Docker Compose configurations that reference Bitnami’s MongoDB images. If your environment attempts to pull these images again (for example, during a re-deployment, scaling, or node replacement), you might encounter “…

Follow the docs properly and use a .env file

> **[Deploy Rocket.Chat with Docker & Compose](https://docs.rocket.chat/v1/docs/deploy-with-docker-docker-compose)**
>
> Set up Rocket Chat using Docker and Docker Compose. Ensure secure communication, operational resilience, and scalable collaboration on self-hosted servers.

And

> **[GitHub - RocketChat/rocketchat-compose: Docker / Podman Compose](https://github.com/RocketChat/rocketchat-compose)**
>
> Docker / Podman Compose

---

<div class="post-metadata">

**Author:** ![kionez](https://avatars.discourse-cdn.com/v4/letter/k/bbce88/32.png) [@kionez](https://forums.rocket.chat/u/kionez)\
**Post date:** [January 16, 2026, 7:32am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/4 "2026-01-16T07:32:53Z")

</div>

Following the official doc and using the RocketChat/rocketchat-compose repo you can’t install the minimum required verson of MongoDB (8.2), because it uses the bitnamilegacy and the last version available is 8.0

> <https://github.com/RocketChat/rocketchat-compose/blob/0abe720db3a873ccec7a5a904482ee010c6d8596/compose.database.yml#L29>

> **[bitnamilegacy/mongodb - Docker Image](https://hub.docker.com/r/bitnamilegacy/mongodb/tags)**

---

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [January 16, 2026, 8:15am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/5 "2026-01-16T08:15:44Z")

</div>

Hello and thanks for the reply.

I had read the link about the Bitnami Image and as I was using ver 7.13.x, this didn’t seem to cause me any issues. However moving to v8.x, there is the need to use MongoDB v8.2, and I couldn’t see details in the ‘Deploy using Docker’ about the correct MongoDB image to pull.

My fresh install, using the docker.compose file, automatically pulled bitnamilegacy/mongoDB v6.0.

Just a bit confused which MongoDB image should be pulled via the docker.compose (for RC v8.x) and why it isn’t using the instructions provided.

Thanks

---

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [January 16, 2026, 9:12am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/6 "2026-01-16T09:12:55Z")

</div>

Hi @kionez

So the compose.database.yml needs to be modified to point to a different repo.

I have found the official mongo repo and edited line 29 in my compose.database.yml:

image: [docker.io/mongo:${MONGODB\_VERSION:-8.2}](http://docker.io/mongo:$%7BMONGODB_VERSION:-8.2%7D)

This worked (in terms of pulling the v8.2 Mongo image:

REPOSITORY TAG IMAGE ID CREATED SIZE  
mongo 8.2 ac3eefab8be5 10 hours ago 916MB  
registry.rocket.chat/rocketchat/rocket.chat latest a7ffcd32a37f 3 days ago 1.22GB  
alpine latest e7b39c54cdec 4 weeks ago 8.44MB  
nats 2.11-alpine ed6a2ea86996 4 weeks ago 26.2MB  
traefik v3.4 aa215d9f973d 5 months ago 226MB  
prom/prometheus v3.4.2 9e24e9a9806c 6 months ago 304MB  
grafana/grafana 12.0.2 4f2ba943b1de 7 months ago 681MB  
natsio/prometheus-nats-exporter 0.17.3 303cae1cf80e 8 months ago 18.3MB  
prom/node-exporter v1.9.1 255ec253085f 9 months ago 25MB  
percona/mongodb\_exporter 0.44.0 e61acbf934e9 9 months ago 20.8MB  
bitnamilegacy/mongodb 6.0 7ffa7118a17b 23 months ago 585MB

and the image is running:

37868b69fb27 mongo:8.2 “docker-entrypoint.s…” 8 minutes ago Up 8 minutes 127.0.0.1:27017-\>27017/tcp

Looking at the logs for Mongo there are errors:

{“t”:{“$date”:“2026-01-16T08:53:00.322+00:00”},“s”:“I”, “c”:“EXECUTOR”, “id”:22988, “ctx”:“conn61”,“msg”:“Error receiving request from client. Ending connection from remote”,“attr”:{“error”:{“code”:141,“codeName”:“SSLHandshakeFailed”,“errmsg”:“SSL handshake received but server is started without SSL support”},“remote”:“172.25.0.4:54762”,“connectionId”:61}}

And the logs for the rocket.chat container are showing:

MongoServerSelectionError: Server selection timed out after 30000 ms  
at Topology.selectServer (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/sdam/topology.ts:628:30)  
at Topology.\_connect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/sdam/topology.ts:468:22)  
at Topology.connect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/sdam/topology.ts:405:7)  
at topologyConnect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/mongo\_client.ts:620:9)  
at MongoClient.\_connect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/mongo\_client.ts:632:7)  
at MongoClient.connect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/mongo\_client.ts:544:7)  
at autoConnect (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/operations/execute\_operation.ts:139:7)  
at abortable (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/utils.ts:1492:12)  
at executeOperation (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/operations/execute\_operation.ts:69:9)  
at Collection.createIndex (/app/bundle/programs/server/npm/node\_modules/meteor/npm-mongo/node\_modules/mongodb/src/collection.ts:609:21)  
at MongoConnection.createIndexAsync (packages/mongo/mongo\_connection.js:507:3)  
at Collection.createIndexAsync (packages/mongo/collection/methods\_index.js:49:7)  
at setupUsersCollection (packages/accounts-base/accounts\_server.js:1844:3)  
at AccountsServer.init (packages/accounts-base/accounts\_server.js:134:5) {  
errorLabelSet: Set(0) {},  
reason: TopologyDescription {  
type: ‘ReplicaSetNoPrimary’,  
servers: Map(0) {},  
stale: false,  
compatible: true,  
heartbeatFrequencyMS: 10000,  
localThresholdMS: 15,  
setName: ‘rs0’,  
maxElectionId: null,  
maxSetVersion: null,  
commonWireVersion: 0,  
logicalSessionTimeoutMinutes: null  
},  
code: undefined  
}

packages/core-runtime.js:189  
throw error;  
^  
errorClass [Error]: [An error occurred when creating an index for collection "users: Topology is closed]  
at Collection.createIndexAsync (packages/mongo/collection/methods\_index.js:62:15)  
at module.wrapAsync.self (packages/accounts-password/password\_server.js:1311:1) {  
isClientSafe: true,  
error: ‘An error occurred when creating an index for collection "users: Topology is closed’,  
reason: undefined,  
details: undefined,  
errorType: ‘Meteor.Error’  
}

Node.js v22.16.0

---

<div class="post-metadata">

**Author:** ![mattsches](https://sea1.discourse-cdn.com/flex021/user_avatar/forums.rocket.chat/mattsches/32/801_2.png) [@mattsches](https://forums.rocket.chat/u/mattsches)\
**Post date:** [January 16, 2026, 10:44am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/7 "2026-01-16T10:44:19Z")

</div>

I wonder if we should use `mongodb/mongodb-community-server:8.2-ubi8` instead, but I’m not keen on trying it out.

Unfortunately, the [rocketchat-compose](https://github.com/RocketChat/rocketchat-compose) repo seems to be outdated and still contains the reference to MongoDB v6.

So, I will postpone upgrading until further notice …

---

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [January 16, 2026, 10:58am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/8 "2026-01-16T10:58:44Z")

</div>

Yes, that is what I have thought now!

---

<div class="post-metadata">

**Author:** ![juiceofjam](https://avatars.discourse-cdn.com/v4/letter/j/d2c977/32.png) [@juiceofjam](https://forums.rocket.chat/u/juiceofjam)\
**Post date:** [January 18, 2026, 4:08am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/9 "2026-01-18T04:08:02Z")

</div>

I worked through this over the last 24 hours with a succesful upgrade from RC v7 and MongoDB v7 to RC v8.0.1 and MongoDB v8.2.3 for test docker environment.

Found [here (RC develop compose.yml)](https://github.com/RocketChat/Rocket.Chat/blob/develop/docker-compose-local.yml) line 133:

> mongo:  
> image: mongodb/mongodb-community-server:8.2-ubi8

Upgrade notes:

```auto

## Take backup of existing database for restoration post MongoDB version upgrade ##

# Confirm correct DB name. Make backup of the correct database...
$ docker exec -it rocketchat-mongodb-1 mongosh --eval "show dbs"
admin 128.00 KiB
config 268.00 KiB
local 2.17 GiB
rocketchat 1.38 GiB

# Confirm stats match those shown in Rocketchat-GUI > admin > workspace
docker exec -it rocketchat-mongodb-1 mongosh rocketchat --eval "db.users.countDocuments()" # number of users
docker exec -it rocketchat-mongodb-1 mongosh rocketchat --eval "db.rocketchat_room.countDocuments()" # number of rooms
docker exec -it rocketchat-mongodb-1 mongosh rocketchat --eval "db.rocketchat_message.countDocuments()" # number of messages

# Take backup of DB
$ docker exec -it rocketchat-mongodb-1 mongodump \
  --db rocketchat \
  --archive \
  --verbose \
  > ~/backup/rocketchat-v7-$(date +%Y%m%d).raw

# Verify backup
$ docker cp ~/backup/rocketchat-v7-20260118.raw rocketchat-mongodb-1:/tmp/full.raw	# copy into container
$ docker exec rocketchat-mongodb-1 mongorestore --archive=/tmp/full.raw --dryRun --verbose | tail -20
...
2026-01-17T23:49:57.837+0000	dry run completed
2026-01-17T23:49:57.838+0000	0 document(s) restored successfully. 0 document(s) failed to restore.
# success, no unexpected end of file or other error
# if errors, try replacing the date expression from the backup file name creation with just the word "full" and take backup again

# Cleanup backup dump from the container
$ docker exec -u 0 -it rocketchat-mongodb-1 rm /tmp/full.raw #	execute as user 0(root) within container (permissions req'd).

# Duplicate backup to remote server/file system
$ cp rocketchat-v7-20260118.raw <remote destination>/rocketchat-v7-20260118.raw

# Is the "local" DB to be backed up also? No — the "local" database is MongoDB's internal system database storing replica set oplog, config, and metadata. Backing it up will corrupt replication (rs0 state, elections), and restores do not merge properly across versions.​

## Upgrade container images and new requirements ##

# Alter Compose.yml and .env with changes from bitnami image to mongodb community server image.
# Note changed DB volume mapping (different container internal mount point). See also change of permissions for external (host) volume.

# v7 compose.yml

volumes:
  mongodb_data: { driver: local }

services:
  rocketchat:
    image: registry.rocket.chat/rocketchat/rocket.chat:${RELEASE}
    restart: unless-stopped
    environment:
      MONGO_URL: ${MONGO_URL}
      MONGO_OPLOG_URL: ${MONGO_OPLOG_URL}
      ROOT_URL: <your URL>
      PORT: ${PORT}
      DEPLOY_METHOD: docker
      DEPLOY_PLATFORM: ${DEPLOY_PLATFORM}
    depends_on:
      - mongodb
    expose:
      - ${PORT}
    ports:
      - "${BIND_IP}:${HOST_PORT}:${PORT}"

  mongodb:
    image: docker.io/bitnami/mongodb:${MONGODB_VERSION}
    restart: unless-stopped
    volumes:
      - /<host dir>/mongodb_data:/bitnami/mongodb
    environment:
      MONGODB_REPLICA_SET_MODE: primary
      MONGODB_REPLICA_SET_NAME: ${MONGODB_REPLICA_SET_NAME:-rs0}
      MONGODB_PORT_NUMBER: ${MONGODB_PORT_NUMBER:-27017}
      MONGODB_INITIAL_PRIMARY_HOST: ${MONGODB_INITIAL_PRIMARY_HOST:-mongodb}
      MONGODB_ENABLE_JOURNAL: ${MONGODB_ENABLE_JOURNAL:-true}
      ALLOW_EMPTY_PASSWORD: ${ALLOW_EMPTY_PASSWORD:-yes}

# v8 compose.yml

volumes:
  mongodb_data: { driver: local }

services:
  rocketchat:
    image: registry.rocket.chat/rocketchat/rocket.chat:${RELEASE}
    restart: unless-stopped
    environment:
      MONGO_URL: ${MONGO_URL}
      MONGO_OPLOG_URL: ${MONGO_OPLOG_URL}
      ROOT_URL: <your URL>
      PORT: ${PORT}
      DEPLOY_METHOD: docker
      DEPLOY_PLATFORM: ${DEPLOY_PLATFORM}
    depends_on:
      - mongodb
    expose:
      - ${PORT}
    ports:
      - "${BIND_IP}:${HOST_PORT}:${PORT}"

  mongodb:
    image: mongodb/mongodb-community-server:${MONGODB_VERSION} # changed image source
    restart: unless-stopped
    user: "999:992" # UID:GID defined as per mongodb community server requirement (normally 999:999, we have custom requirement)
    volumes:
      - /<host dir>/mongodb_data:/data/db # changed container directory as per mongodb community server
  # chown -R 999:999 /<host dir>mongodb_data/
    command: mongod --replSet rs0 --bind_ip_all # new requirement
    environment:
  # MONGODB_INITDB_ROOT_USERNAME: root # optoinal for community edition
  # MONGODB_INITDB_ROOT_PASSWORD: secret # optional
      MONGODB_REPLICA_SET_MODE: primary
      MONGODB_REPLICA_SET_NAME: ${MONGODB_REPLICA_SET_NAME:-rs0}
      MONGODB_PORT_NUMBER: ${MONGODB_PORT_NUMBER:-27017}
      MONGODB_INITIAL_PRIMARY_HOST: ${MONGODB_INITIAL_PRIMARY_HOST:-mongodb}
      MONGODB_ENABLE_JOURNAL: ${MONGODB_ENABLE_JOURNAL:-true}
      ALLOW_EMPTY_PASSWORD: ${ALLOW_EMPTY_PASSWORD:-yes}

# v7 environment file

# Rocket.Chat version
# see:- https://github.com/RocketChat/Rocket.Chat/releases
RELEASE=7.8.0
# MongoDB endpoint (include ?replicaSet= parameter)
MONGO_URL=mongodb://mongodb:27017/rocketchat?replicaSet=rs0
# MongoDB endpoint to the local database
MONGO_OPLOG_URL=mongodb://mongodb:27017/local?replicaSet=rs0
# IP to bind the process to
BIND_IP=<your IP>
# URL used to access your Rocket.Chat instance
ROOT_URL=<your URL>
# Port Rocket.Chat runs on (in-container)
PORT=3000
# Port on the host to bind to
HOST_PORT=3000
# Added this in response to the warning of variable not set
DEPLOY_PLATFORM=selfhosted

### MongoDB configuration
# MongoDB version/image tag
MONGODB_RELEASE=7.0
# See:- https://hub.docker.com/r/bitnami/mongodb
MONGODB_VERSION=7.0

# v8 environment file

# Rocket.Chat version
# see:- https://github.com/RocketChat/Rocket.Chat/releases
RELEASE=8.0.1
# MongoDB endpoint (include ?replicaSet= parameter)
MONGO_URL=mongodb://mongodb:27017/rocketchat?replicaSet=rs0
# MongoDB endpoint to the local database
MONGO_OPLOG_URL=mongodb://mongodb:27017/local?replicaSet=rs0
# IP to bind the process to
BIND_IP=<your IP>
# URL used to access your Rocket.Chat instance
ROOT_URL=<your URL>
# Port Rocket.Chat runs on (in-container)
PORT=3000
# Port on the host to bind to
HOST_PORT=3000
# Added this in response to the warning of variable not set
DEPLOY_PLATFORM=selfhosted

### MongoDB configuration
# MongoDB version/image tag
MONGODB_RELEASE=8.2-ubi8
# See:- https://hub.docker.com/r/mongodb/mongodb-community-server
MONGODB_VERSION=8.2-ubi8

# Pull images.
$ cd <compose dir>
$ docker compose pull

# Stop (not down). Stop preserves networks and volumes.
$ cd <compose dir>
$ docker compose stop

# remove old Rocketchat container only (part of regular Rocketchat upgrade procedure, not part of mongoDB upgrade)
$ docker rm rocketchat-rocketchat-1
rocketchat-rocketchat-1

# Set file permissions for Mongodb community server.
$ ls -lhn /<host dir>/rocketchat/
drwxrwxr-x+ 3 1001 0 4.0K Nov 12 2022 mongodb_data
$ sudo chown -R 999:992 /<host dir>/mongodb_data/
$ sudo chmod -R 755 /<host dir>>/mongodb_data/

## Configure v8.x mongodb community server ##

# Up. (note RC container will fail to connect to DB. continue with following steps to configure DB.
$ cd <compose dir>
$ docker compose up -d

# Check replica set status (should be not enable at this stage)
$ docker exec -it rocketchat-mongodb-1 mongosh --eval 'rs.status()'
MongoServerError: no replset config has been received

# enable replica and verify
$ docker exec -it rocketchat-mongodb-1 mongosh --eval 'rs.initiate({ _id: "rs0", members: [{ _id: 0, host: "mongodb:27017" }] })'
"mongodb:27017" }] })'
{
  ok: 1,
  ...
$ docker exec -it rocketchat-mongodb-1 mongosh --eval 'rs.status()'
...
  members: [
  ...
      stateStr: 'PRIMARY',
...
  ok: 1,

# stop and re-up.
$ docker compose up -d

# confirm compatibilty version set to 8.x
$ docker exec -i rocketchat-mongodb-1 mongosh --eval "db.adminCommand( { getParameter: 1, featureCompatibilityVersion: 1 } )"
...
  featureCompatibilityVersion: { version: '8.2' },
  ok: 1,
...

## Restore DB from backup ##

# Stop Rocketchat container to avoid DB conflicts/corruption.
$ docker compose stop rocketchat-rocketchat-1

# Copy DB backup dump into container and dry run restore
$ docker cp ~/backup/rocketchat-v7-20260118.raw rocketchat-mongodb-1:/tmp/full.raw # copy into container
$ docker exec rocketchat-mongodb-1 mongorestore --archive=/tmp/full.raw --dryRun --verbose | tail -20 # dry run

# Restore database
$ docker exec rocketchat-mongodb-1 mongorestore --archive=/tmp/full.raw --nsInclude=rocketchat.* --drop
...
2026-01-18T00:21:33.981+0000	19613 document(s) restored successfully. 0 document(s) failed to restore.

# Restart Rocketchat & mongoDB
$ docker compose up -d

# Confirm versions
Rocketchat GUI > admin > workspace	*refresh*
Verify expected Rocketchat and MongoDB versions.

# Cleanup backup dump from within mongodb container
$ docker exec -u 0 -it rocketchat-mongodb-1 rm /tmp/full.raw

```

---

<div class="post-metadata">

**Author:** ![brecklinghaus](https://avatars.discourse-cdn.com/v4/letter/b/a183cd/32.png) [@brecklinghaus](https://forums.rocket.chat/u/brecklinghaus)\
**Post date:** [January 19, 2026, 11:04am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/10 "2026-01-19T11:04:08Z")

</div>

> Same issue here with a docker deployment. If you update MongoDB to latest, the database container fails to start. Update Mongo to 7.x (I don’t remember the exact version right now) solves the problem for now.

---

<div class="post-metadata">

**Author:** ![GilesOGram](https://avatars.discourse-cdn.com/v4/letter/g/76d3ee/32.png) [@GilesOGram](https://forums.rocket.chat/u/GilesOGram)\
**Post date:** [February 3, 2026, 8:52am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/11 "2026-02-03T08:52:00Z")

</div>

Seems like the docker.compose file has be ‘fixed’! Deployed a fresh installation and it has pulled MongoDB v8.x

---

<div class="post-metadata">

**Author:** ![reetp](https://sea1.discourse-cdn.com/flex021/user_avatar/forums.rocket.chat/reetp/32/5546_2.png) [@reetp](https://forums.rocket.chat/u/reetp)\
**Post date:** [February 3, 2026, 9:30am UTC](https://forums.rocket.chat/t/rc-v7-x-to-v8-0-1-needing-to-upgrade-mongodb-to-v8-2/22676/12 "2026-02-03T09:30:04Z")

</div>

> [@\[ACTION REQUIRED\] Docker Compose Moving from Bitnami to Official MongoDB Image](https://forums.rocket.chat/t/action-required-docker-compose-moving-from-bitnami-to-official-mongodb-image/22693/1):
>
> Upgrading Rocket.Chat Docker Compose to MongoDB 8.2 This guide explains how to migrate from the current Bitnami MongoDB 6.0 deployment to the official MongoDB 8.2 image. Background & Why This Upgrade Is Necessary Over the past several years, Bitnami has been the go-to provider for MongoDB images in our Docker Compose deployments. However, significant changes in the community have necessitated a shift in strategy: Recent Events: Bitnami Acquisition Impact: Bitnami was acquired by VMware (whi…
