Push Notification Via FCM to Apple Devices

Push notifications are not sent to ios, but on android everything works without problems on the React Native Client (changed bundle id and plist\google services).
Self hosted server, we use FCM . where the key for APN is registered.

The Rocket Chat server push notification configuration includes the GCM API Token and the GCM Project Number.
According to the logs it is clear that the pushies should go, but they do not come.
What could be the reason?
Perhaps we need to use APN certificates separately from FCM?

Server Setup Information

  • Version of Rocket.Chat Server: 2.3.0
  • Operating System: Linux
  • Deployment Method: snap
  • Number of Running Instances: 3
  • DB Replicaset Oplog: 168
  • NodeJS Version: v8.11.4
  • MongoDB Version: 4.0.13
  • Proxy: nginx
  • Firewalls involved: -

Any additional Information

I20200114-02:19:40.862(3) Create GCM Sender using “<–hidden–>”
I20200114-02:19:40.862(3) A:Send message to: “<–hidden–>”
I20200114-02:19:40.864(3) send to token { apn: '"<–hidden–>" ’ }
I20200114-02:19:40.864(3) Push: Sent message “olegtest” to 3 ios apps 1 android apps
I20200114-02:19:41.259(3) ANDROID: Result of sender: {“multicast_id”:8143479216614887000,“success”:1,“failure”:0,“canonical_ids”:0,“results”:[{“message_id”:“0:1578957581232019%9b5a33060034af1a”}]}
I20200114-02:19:50.696(3) Push: Send message “olegtest” via query { userId: ‘kev9Jy4cWKmy8RSTP’ }
I20200114-02:19:50.698(3) send to token { apn: '"<–hidden–>" ’ }
I20200114-02:19:50.698(3) send to token { apn: '"<–hidden–>" ’ }
I20200114-02:19:50.698(3) send to token { gcm: '"<–hidden–>" ’ }

I20200114-02:19:50.699(3) sendGCM [ '"<–hidden–>" ’ ] { _id: ‘vBWoTJJL4YwjHPDoc’, createdAt: 2020-01-13T23:19:50.015Z, createdBy: ‘’, from: ‘push’, title: ‘olegtest’, text: ‘ss’, payload: { host: '"<–hidden–>" ', rid: ‘2zmh7yDSKjWonBXLwkev9Jy4cWKmy8RSTP’, sender: { _id: ‘2zmh7yDSKjWonBXLw’, username: ‘olegtest’ }, type: ‘d’, messageId: ‘RWXxwqP6wf3PYCJA6’ }, badge: 1, sound: ‘default’, notId: -25253760, apn: { category: ‘MESSAGE’ }, gcm: { image: '"<–hidden–>" ', style: ‘inbox’, summaryText: ‘%n% new messages’ }, query: { userId: ‘kev9Jy4cWKmy8RSTP’ }, sent: false, sending: 0, image: '"<–hidden–>" ', style: ‘inbox’, summaryText: ‘%n% new messages’ }
I20200114-02:19:50.702(3) Create GCM Sender using “”<–hidden–>" "
I20200114-02:19:50.703(3) A:Send message to: eqpo9ZVam4k:"<–hidden–>"
I20200114-02:19:50.703(3) send to token { apn: ‘ce997e61b7f4de408297ea7ffcd5a84ad33bc9d3646b461250427daf6ea4c1e7’ }
I20200114-02:19:50.703(3) Push: Sent message “olegtest” to 3 ios apps 1 android apps
I20200114-02:19:50.755(3) ANDROID: Result of sender: {“multicast_id”:8042224112361969000,“success”:1,“failure”:0,“canonical_ids”:0,“results”:[{“message_id”:“0:1578957590725724%9b5a33060034af1a”}]}

I solved the problem myself - indeed, to work with apple, you need to download APN certificates

Hi, can you help me out in setting up push notifications?