Migration issue, redirecting to localhost


<-Please note, the spaces in “links” are there because the forum software does not like them->

I have installed Rocket Chat using snap with a Apache proxy. This is working fine but when I import a dump from a different instance I need to migrate it starts to redirect to h t t p s : / / /.

There are no issues with the import of the dump, also no errors in the logs of RC or Apache.

Server Setup Information

  • Version of Rocket.Chat Server: 1.2.3
  • Operating System: Ubuntu 18.04
  • Deployment Method: snap
  • Number of Running Instances: 1
  • NodeJS Version: 8.11.3
  • MongoDB Version: 3.4.20
  • Proxy: apache
  • Firewalls involved: iptables

Any additional Information

The Apache proxy config:

RewriteEngine On
RewriteCond %{HTTP:Upgrade} =websocket [NC]
RewriteRule /(.) w s : / / :3000/$1 [P,L]
RewriteCond %{HTTP:Upgrade} !=websocket [NC]
RewriteRule /(.
) h t t p : / /$1 [P,L]

ProxyPassReverse / h t t p : / /

I noticed in the initial install the Site URL was listed as h t t p : / / localhost, now this is the URL used externally ( h t t p s : / / chat.example.org). I tried to change it but this does seem possible. I used “snap set rocketchat-server siteurl= h t t p : / / localhost” as documented.

I do not know the configuration of the previous host which is likely the issue.

Many thanks for any help on this in advance.

Found the issue, it was the Force_SSL setting, managed to fix it directly in the database. The snap way of changing settings seems broken on my system, I tried setting it that way before.

In the command line I did the following.

~# mongo
use parties
db.rocketchat_settings.update({ _id: “Force_SSL” }, { $set: { value: false } });